Jump to content
Sign in to follow this  

yz 125 races in 4 days help!!

Recommended Posts

Hey guys Im new here i dint know who else to turn to. sorry if it the wrong section but im in panic mode. this is what happened. i was riding and me and the bike flipped into water the bike went completely under while it was on. I took everything off the bike crack the motor open had to replace the power valve pushrod that i broke got new gaskets new clutch fresh fluids. i put the bike together but it still not starting! there was water in the motor BTW. I got spark but i cant tell if its a strong spark carb is completly clean. It looks to me that the spark plug is getting wet somehow but idk idk idk im so lost and im so stressed out i really wanted to start the series with a bang 4 days left :):lol:

Share this post


Link to post
Share on other sites

theres a good chance you need to replace ur main bearings in the bottom end. next time that happens the first thing u should do is flip ur bike upside-down and push the kickstarter with ur hand to pump the water out of the exhaust. then keep tryin to start it till she fires

Share this post


Link to post
Share on other sites

i did do that after it went under water i had to be towed in by an atv witch one is the main bearing. a lil smoke came out the back yesterday after i kicked it. the first kick sounded like it wanted to start but then nothing what can get spark plug wet. looks like dirty water but i thought i cleaned out all the water. can coil packs go bad if they get wet?

Share this post


Link to post
Share on other sites

im gonna try 1 last thing. i should prob get premium gas i forgot and put regular in it"been of the bike 2 long" and imma go get a new spark plug be back in a few hours

Share this post


Link to post
Share on other sites

Water in your gas tank possibly? and in the carb.....

Rec. draining your fuel tank and putting new gas in. Also pull the carb. and do a quick cleaning and see if you have any luck...

Share this post


Link to post
Share on other sites

the main bearing is the bearing on the crank. find a diagram on the web for your yz125. Coil packs could go bad if they got wet, but they shouldnt, otherwise powerwashing bikes would be a bad idea, maybe if the bike is old.

Share this post


Link to post
Share on other sites

yeah def try some of that stuff befor u split the case for the mainbearings, because if thats wats wrong theres very slim chance ur bike is gonna be ready in 4 days.

Share this post


Link to post
Share on other sites

You probably still have water in the bottom end, in the fuel tank, or in the carburetor.

1) Take off your tank and dump out the old gas.

2) Take the drain plug out of the carburetor and let the fuel drain out of the float bowl.

3) Before you fill the tank with new gas, take the spark plug out and spray a little WD-40 into the cylinder through the spark plug hole. Next, either roll the bike down a hill with the throttle wide open or kick over the engine about 100 times with the throttle wide open.

The WD-40 will keep your top-end lubed and help displace any water that comes through. You only need a little spray, maybe 1/2 second through the spark plug hole. Don't drown it out.

Those three actions should clear out your fuel system and your engine of any water.

When you're done, check for spark with a fresh plug. If you aren't getting spark, check to make sure the electrical connections are dry and tight.

When you put in fresh fuel and a fresh spark-plug, it should fire right up.

Share this post


Link to post
Share on other sites

Also, did you clean and dry the air filter and the air boot?

I've seen a friend pressure wash his bike and get a little water in through the air filter. The water pooled up in the air boot just behind the carb, so a little more would get sucked in each time he tried to start it.

Share this post


Link to post
Share on other sites

man thank guys!!! i dint think thumpertalk would have this much support. well i got the bike started. and ive cleaned everything in the motor new gaskets i had the bike completely appart. but today i got premium gas and a spark plug i pushed the bike down the street and popped the clutch and the motor was turning over but no conbustion. pushed it up the street and again popped it and gave it gas sounded it like it wanted to start so i stayed on the bike and kept pumping the gas I heard. braa braa braa finally braaaaaapppP!!! i got SO HAPPY that i did a wheelie and pinned it to 3rd. but completly forgot that i had no brake calipers in the front and back the bike was stripped. took out a few neighbors yards but did not FALL!! :lol: thank god. i was scared lol.. but thanks for all the help everyone Ill be on here more often wish me luck for friday!!

Share this post


Link to post
Share on other sites

glad you got it going. that is the most frustrating thing when you bike messes up right before a big race

Share this post


Link to post
Share on other sites

wait what lol you had 3rd gear pinned and had no brakes what?! lol

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×