Jump to content
Sign in to follow this  

08 RMZ 450 FI Problem

Recommended Posts

Have an 08 RMZ 450 and Bike began cutting out at anything more than 1/4 throttle. After reading thru manual and some other TT posts on same subject, I purchased a FI diagnostic FI light and battery lead wire. The FI indicator light showed a problem 41 which is an FP relay circuit malfunction. Following the manual, I unplugged my ECM and checked the voltage at the ECM harness side coupler and it matched the battery voltage. Next I checked the continuity of the wiring from the harness side ECM coupler to the coupling for the fuel pump hookup and it was fine. Plugging ECM back in and the hooking up the battery showed a voltage at the FP connector red/black to be roughly 7 volts less than the battery voltage, 12.8V to 4.6V. Is this correct voltage for the feul pump? If so, is the problem the relay in the ECM and does that then need replacement? Any info you have would be helpful.

Share this post


Link to post
Share on other sites

The Fuel Pump Relay is internaly located on the ECM. When powered up with 12v, test on pin location #14 to ground. Relay should be letting same voltage as applied +/- 2%.

If it is not, then your ECM need to be replaced. Yoshimura PIM-2 time!!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×