Jump to content
Sign in to follow this  

New SSR125 SR Carb Issues?

Recommended Posts

Just recently purchased two new in crate SSR125 Sr's.

So far both run great execpt for that they do not idle or idle too high and if you give it full throttle it bog.

Give it too much gas to fast, it will bog and die. It seems to be a little better after break in and if I'm going down a hill I can give it more gas and it will not bog down as much.

As for idling, it will either not idle or idle great, then give it some gas and idle too high (hanging idle), almost like an air leak, but both bikes do the same thing and both are new.

I'm thinking it's running to lean but want to see what others think.

Share this post


Link to post
Share on other sites

Thanks, ive tried lowering the clip all the way down and have the mixture screw turned 1/2 way out from all the way in. Seemed to help out idle and throttle response a tad but still bogs on top end. Im going to try those tips on your site!

Share this post


Link to post
Share on other sites

I just rode it today with these new settings, ran like crap.. Worse than before, not better.

Found out it was too rich, leaned it out all the way on the clip and runs MUCH BETTER!!!

I can open it up to 3/4 throttle but still bogs on top end.

It actually idles great now, just the way it should and starts first kick with out opening the throttle!!

Gonna try leaning out the main jet a size or two and see how it goes!!

Share this post


Link to post
Share on other sites

Got the kit today, the thread size of the jet is way to small. It just slips right in and out. The stock main jet is a size 86.

Share this post


Link to post
Share on other sites

A picture of the carb and the jets you have would be a much bigger help than a generic picture of the bike.

Share this post


Link to post
Share on other sites

It's a 26mm Keihn clone carb.

I'll take a pic later..

Share this post


Link to post
Share on other sites

Yeah I'm pretty lean,bogs a tiny bit uphill in 4th gunning it,but will get to full throttle no prob if Im in the hi RPMs,its and old SSR,but put a Lifan w/ its stock carb and pretty much kept the same settings.

I think my whole problem was an exhaust leak,cuz after I fixed that it runs great.

My buddy had to buy a new carb for his BBR knockoff (jailing engine?),cuz there was a pin broken in it,had to take it to in,we just couldnt get it right.

Im probably 1/2 out from all the way in on the mixture screw,and just a touch on the overflow screw.

Share this post


Link to post
Share on other sites

I'm 1/4 out from all the way in.. seems to run good and idle great like this.

Share this post


Link to post
Share on other sites

I can't believe I'm so stupid!!! Choke was on the whole time!!

Opened it up and set the needle one step richer than stock and it runs great throughout the whole powerband!! Idles great too!!

Thanks everyone!! Can't believe I didn't see this earlier lol

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×