Jump to content
Sign in to follow this  

Leaking antifreeze!!!

Recommended Posts

2004 yz 250f, dripping anti freeze out of the front of the head, not where cylinder and head meet (Not a head gasket issue). It looks like it's leaking out of a metal price that come out of the front of the cylinder, drips when I rev pretty bad. Is that price castes to thehead? Anyone else ever had this issue? I am pissed because I just did some major maintenance and now another problem pops up. Amy quick fixes please respond. Tia.

Share this post


Link to post
Share on other sites

pictures of course would help....

there is a metal elbow that connects via rubber hose to the left radiator, this is the outlet of the head for coolant to flow...i believe it has a rubber o-ring or 2 of them that fit around the elbow and then this slides into the cylinder head and is pressure fit in there, then a bolt holds it in place (kind of a weak set up if you ask me)

i would check this connection and make sure those o-rings werent damaged somehow...

also check the hose clamps on all of the coolant system to make sure they are tight

you can also drain the coolant through the water pump and then just use your hand and an air compressor and blow some compressed air in there, should tell you where your leak is quickly...(dont use too much air, maybe 30 psig)

http://www.motosport.com/dirtbike/oem-parts/YAMAHA/2004/YZ250F/RADIATOR-HOSE

on this diagram it is parts 10, 11, 12...check those connections

Share this post


Link to post
Share on other sites

So i go down to the garage last night and look @ the bike. Anti freeze is slowly dripping from that metal peice coming out of the cylinder. Since the motor was not running the assumption would be it is gravity driven and must be coming from above (the radiator hose that feeds into it) . Does that make sense, i am just trying to pin down the leak and am having a hard time. BTW I went riding for 2 hours pon Sunday w/the slow leak and had to add approx 4 ounces. think its ok to continue to do this until snow falls and then clear up the problem?

Share this post


Link to post
Share on other sites

this is on the front of the cylinder where the fluid leaves the head and goes up to radiator. Can you give me a better description of where the weep hole is?

Share this post


Link to post
Share on other sites

Sounds like your hose might be loose.

Whatever it is I wouldn't run it much until you figure it out.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×