Jump to content
Sign in to follow this  

brake light actuator not working

Recommended Posts

the brake light on my drz400s seems to always be on. Nothing happens when I pull the front lever, where can I start to solve the problem. There is an actuator on the lever.

Share this post


Link to post
Share on other sites

YOU RULE!! This has been an issue for like 2 months and its finally fixed, Thank you very much. for some reason I never though to look on the rear brake : ) : )

Share this post


Link to post
Share on other sites

My rear brake switch has been acting up too. Ive actually been pulling up on the pedal with my foot to turn my brake light off. I'll be cleaning the switch up in the morning :lol:

Share this post


Link to post
Share on other sites
My rear brake switch has been acting up too. Ive actually been pulling up on the pedal with my foot to turn my brake light off. I'll be cleaning the switch up in the morning :lol:

You might want to grease the brake pedal pivot and check the return spring:thumbsup:

Share this post


Link to post
Share on other sites

On mine for some reason the actuator on the rear had pivoted out a little so the screw wasn't depressing it when the break pedal was up, just moved it back over and we were back in business

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×