Jump to content
Sign in to follow this  

IMS Tank Interference

Recommended Posts

I have an 09 with 14 hours on it and an IMS 3.2 tank. I pulled it off yesterday to check the valve clearance (all in spec) and noticed 2 wear marks from the tank on the valve cover. 1 is on the top of the valve cover which is just a tank rub mark and not a big deal. The other is from the down tube for fuel which has rubbed away a bit of aluminum (1/16") on the side of the valve cover in the area where the indent is for the spark plug. The valve cover is not that thick so I am concerned with it rubbing through. Anybody else seen this? I was thinking of putting a thin coat of JB weld in the area as it is tougher than aluminum. And yes, I should have taken a picture. Next time I pull off the tank will be for an 08 R cam.

Share this post


Link to post
Share on other sites

Thanks, I ordered the rubber mounts today. I wish I would have known it before I installed the tank and it did the damage. $8 mounts versus $153 head cover if I was to replace it. The last post asked amount mounting location and was not answered - suggestions?

Share this post


Link to post
Share on other sites

Couldn't tell you exactly. Your best bet is to get someone with an 05-07 to take a photo or tell you, but I assume it would be under the wider section of the IMS tank.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×