Jump to content
Sign in to follow this  

tail light issue

Recommended Posts

since i have had this bike it has had the taillight on a switch that you physically had to turn on to get the light to work(street legal kit from previous owner) it is wired direct to the battery so while taking care of other issues, i thought i would put it back correct, but when i plug the factory light into the black and grey, it wont work anymore. the fsm doesnt really go into much detail on the tailight wiring and trouble shooting. anyone had this issue and solved it?

Share this post


Link to post
Share on other sites
since i have had this bike it has had the taillight on a switch that you physically had to turn on to get the light to work(street legal kit from previous owner) it is wired direct to the battery so while taking care of other issues, i thought i would put it back correct, but when i plug the factory light into the black and grey, it wont work anymore. the fsm doesnt really go into much detail on the tailight wiring and trouble shooting. anyone had this issue and solved it?

Sounds like the ECM was fried when the lighting kit was installed (without dissconnecting the battery to prevent shorts). A common problem.

Share this post


Link to post
Share on other sites

the headlight works correctly, would that have any effect on the ecm? meaning fried for sure:banghead:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×