Jump to content
Sign in to follow this  

my crf250 x wont start with the electric starter

Recommended Posts

hi everyone:) can anyone help me bike will not start with the electric starter, i had a little accident like we all do i ve broken the rear brake light and ever since it does not start???? ive checked fuse OK< i had to take horn off as it fell off but taped up cables ?? any thoughts

Share this post


Link to post
Share on other sites

Check the battery wires them selves they may have come loose then when you crashed fianlly come all the way off also fix the rear light maybe its causeing there not to be a complete circuit....Does the starter make any sort of noise when you hit the start button.

Share this post


Link to post
Share on other sites

if its not clicking or trying to turn over when you hit the switch, you may have busted the actual switch. just happened to mine.

Share this post


Link to post
Share on other sites

hi thanks for reply, , starter does not make any noise there is nothing at all?? ive ordered new back light and hopefully this might work to keep circuit in a loop.fingers crossed its so much easier with a button:)

Share this post


Link to post
Share on other sites

+1. the obvious fuse is just a spare in a holder, the real one that also fuses the rear light is hidden

Share this post


Link to post
Share on other sites
+1. the obvious fuse is just a spare in a holder, the real one that also fuses the rear light is hidden

+1.. the acual fuse is under the rubber boot that holds the spare fuse on the starter relay. Fuse feeds power to the tail light and likely shorted and blew.

Share this post


Link to post
Share on other sites

just reaching here, but between the rear fender and sub fram on the right side at the rear of the subframe there is wiring. it's like a large wire from the battery. that may be the fuse you said you checked i have never looked at it much so i don't know what it is but it looks like it is from the battery. just trying to give you something to look for.

What about the clutch lever switch, could that be bad?

Share this post


Link to post
Share on other sites
+1. the obvious fuse is just a spare in a holder, the real one that also fuses the rear light is hidden

My rear light isn't working, is that the fuse I need to check?!:bonk::doh:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×