Jump to content
Sign in to follow this  

@003 KLX Engine Noise

Recommended Posts

I have a engine noise on the KLX i just bought and it runs good but the noise I cant stand. I have tighten the cam tensioner and it is still there. It does not sound like a rod to me. It sounds like it is in the top end. I found a video on youtube of a bike that makes the same sound.

tell me what you thing it is before I start throwing money at it.

Share this post


Link to post
Share on other sites

Sounds are very hard to diagnose long distance. Also, if that's not your bike, its someone elses, then that might not be the issue.

If it's not cam chain, then it must be valve lash. I'd say pull the caps and check the valves. Usually .003" to .004" is OK, more than that and it will become noisy. Check the book for exact specs.

I'd also pull the chain tensioner and make sure it does lock out like it should.

Share this post


Link to post
Share on other sites

I have done everything except the valves. I have one more question. On the oil site glass as long as it is full with the engine off that is fine correct? Also it does not sound like my valves as it is in the middle where the noise is. Sounds like the chain but the tensioner is working....maybe wore out? I have heard other ones on youtube that sounded like this. There is not way it sounded like this from the factory. As for tha vlaves, how do you adjust them? do they have a rocker arm with a adjuster built in? or is there someting else

I have to do?

Share this post


Link to post
Share on other sites

The KLX250/300/250 have always had cam chain noise. It is the nature of the beast. There is a guy out there somewhere making a manual chain tensioner for the KLX that makes it run quieter. Total cam chain failures with the stock KLX tensioner are rare.

Share this post


Link to post
Share on other sites

Yes, with the engine off, the oil should be between the top and bottom marks on the side of the site glass. Nope, 03 uses shim and bucket design, so its not as easy to adjust. You might want to hold off running the motor until you nail down the noise.

Share this post


Link to post
Share on other sites

Do not keep running the engine with valve train noise . Take the bike to the dealer and let them adjust the valves, and let them install a new cam chain while they are at it. It will be cheaper for you in the long run.

As for the oil, change oil and filter, add 1 and 1/4 quarts, start engine let it warm up slowly. when completely warm , shut it off, let it sit for 5 min, hold bike verticle and add apprx another 1/4 quart. I add oil to mine till it is at the top of site glass. FYI .. same oil filter as honda xr 250 and 400.

Share this post


Link to post
Share on other sites

what do you all think it will cost to install a new chain and chain guides and adjust the valves at the dealer?

Share this post


Link to post
Share on other sites

maybe 200 bucks. not sure, but thats alot cheaper than you not knowing, or worst, getting it wrong. a service manual is 80 bucks.....the shims are apprx 5 bucks each.. getting it wrong and bending or mushrooming a valve.. well just get your billfold ready. Once you have it done you may not have to have it done again for 1-2 yrs. ( valve adjust) You can learn in that amount of time) it will be hard to start when they need adjusting or the acr (automatic compression release) will need adjusting. see brewster on the acr fix. REMEMBER THIS!! .. PUSH the kick starter down dont kick hell out of it, or it will break the clip that holds the idler gear or the gear, and the gear can come off and possibly break the engine center case. better have a thick billfold for that. I can start mine with my hand when the engine is hot. Once you've owned one of these ( i have 2 ) and know the shortcomings and take care of it ,it will be as reliable of a ride as anything else... I use 20w/50 honda oil in mine. not synthetic. never a problem. advice is cheap ... klx parts are not.

Share this post


Link to post
Share on other sites

This bike will start on the first kick, this is why I dont think the valves are to far out. It starts tight up and idles without the choke.....not many other bikes i have have will do that. I ordered a manual. And whn I get a chance I may just pull the engine and check it out. It runs good but the noise I dont like. When I get a chance I will video it running so you all can hear it.

Share this post


Link to post
Share on other sites

I took the chain adjuster apart and it seems to be free and clean and working. I just think the chain is loose. Or worn...I will just change the chain and hope for the best.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×