Jump to content
Sign in to follow this  

05 Heat issue

Recommended Posts

I know the 05 runs hot but I just ran my new to me bike for the 1st time today in the dark and within 2 mins the header pipe was glowing red hot. I shut it down and checked the coolant...looked ok and was barely warm. I ran the bike for another minute with the rad cap off and saw swirling action which i presume to be the work of the water pump in action. Again, the coolant is not even hot yet and I again see the header pipe glowing red hot. The guy I bought it from is long gone but he said the top end was completely redone. Is this normal? If not what can I do to cool this beast down...it revs freely and sounds good but I'm afraid I might do some damage if I continue to run it...any help or feedback is aprecciated.

Bruce

Share this post


Link to post
Share on other sites

There isn't anything wrong, it is pretty common. Use the search feature and you will find multiple threads on the same subject. The glowing pipe is from the exhaust gases from combustion and not related to the closed loop cooling. If the bike is running and idling fine and the radiator is not overheating, you are in good shape..... Now go ride that thing!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×