Jump to content
Sign in to follow this  

My new(to me) yz

Recommended Posts

Hi there i recently purchased a 2003 yz 125 for €1200 with a set of pirellis and an OEM kit with a top end kit,some seals and jets etc.

Here it is when i got it

297469_2585210075869_1423044351_32949765_1468117850_n.jpg

381764_2585208715835_1423044351_32949762_1991944883_n.jpg

Here it is after a wash:thumbsup:

379609_2676479037536_1423044351_32999077_1854029548_n.jpg

386170_2676480197565_1423044351_32999079_2057088448_n.jpg

And finally me and my dad went up to Vernon mount a motocross track(keep in mind this is my first proper go on the bike and the track)

388222_2782156479406_1423044351_33040571_1025845861_n.jpg

390774_2782153039320_1423044351_33040567_366170562_n.jpg

And a video

I love this bike it's so powerful for a 125:worthy:

Share this post


Link to post
Share on other sites

nice bike. i had an 03 at one time. the only thing i never could get completely use to was the 5 speed trans...but maybe i shoulda changed my gearing up some.

Share this post


Link to post
Share on other sites

That was my only complaint about the 02-04 Yz, the 5 speed tranny. I was not a fan... the 6 speed tranny was much better IMHO. Still a great bike though, and great riding.

One pointer if you dont mind... downshift that thing and get into the power. The bike will thank you for ringing it out a little. Sounds like you may be a gear high.

Share this post


Link to post
Share on other sites

Thanks guys:thumbsup: Yea I don't really mind the 5 speed tranny I'm only 112lbs or so, so it has no problem hauling me around

@ftball90 thanks coming up to jumps I read somewhere that on a 2t it is best not to be in the powerband because it goes sideways but maybe that isn't true if someone could confirm this that would be great.I wasn't really used to the bike or track but constructive criticism is always welcome.

The track was super wet and made for an interesting ride:ride:

Share this post


Link to post
Share on other sites

once you get the feel for the bike...hold it wide open everywhere (the only way to ride a one two five)

Share this post


Link to post
Share on other sites

One question its currently running stock jetting, once warmed up there isn't a puff of smoke. The plug was black last time i checked and i have no spooge what so ever.Could i be running a little lean?What are signs of running lean?thanks

Share this post


Link to post
Share on other sites

should be a dry caramel/tan color... white is a sign of excess heat (lean), and black shows unburnt fuel/ premix mixture (rich).

I have a plug chart somewhere , Ill post it up for you when I find it.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×