Jump to content
Sign in to follow this  

yz assembly question ?

Recommended Posts

i have a 2003 yz 250 2 st. split cases and renewed all brgs. and seals. the right case cover with pwr. valve installed stops about an 1/8 " from contacting center case, then there is spring tension until the case surfaces meet. i assume its the springs on the pwr. valve. is this normal? or do i need to drive the brg. for the pwr. valve deeper into the case half. i installed the brg. flush but i think there is room to go deeper. it sat apart for 3 wks. so i forgot how that brg. was orig. installed. the brg. i am refering to is the ball brg. on the rite crankcase, just above the primary gear. thanks

Share this post


Link to post
Share on other sites

Sounds like you don't have the gears lined up on the powervalve and crank driven gear.

Rotate the crank while sliding the outer case on. You'll feel them mesh up, then you're good to go.

Share this post


Link to post
Share on other sites

The power valve brg shoulD be flush, not sunk, the teeth just aren't lining up.

Share this post


Link to post
Share on other sites

pwr v. onto brg. meshing gears , then lowering case cover onto engine. pwr v. gear is meshed onto the thin drive gear. the case sealing surfaces are contacting in kickstart area, when you get to the area around the pwr v. maybe an 1/8 or less approx. there is a gap. push on case cover and it closes up but you feel spring tension from pwr. v. so in your exp. this is not correct? excuse my poor explainition. thanks

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×