Jump to content
Sign in to follow this  

97 kx 250 questions

Recommended Posts

I have a few questions about my 97 kx 250. First I will give a little story with it. I had a guy bring it to my brothers powder coating shop about 3 months ago. Long story short he inherited a house and the bike was in the building. He says he new it hadnt been ran for at least 3 years. We gassed it up and it started after about 6 kicks. Bike looks very good for a 97. We ran it for about 1 minute before I thought to check the trans oil...looked in the window and didnt see any:bonk:. Anyway I added oil and rode the crap out of it. The biggest problem I have with the bike now is when its cold it is a bear to start. It has spark and gas, just a absolute beast to start. After we have been riding it is fine starts first kick. Any ideas?

I will be putting a new clutch in this winter and whatever else I need as the clutch really rattles in this bike bad, and it is very stiff. I also am looking for some decals for the bike but its hard to find anything reasonable for a 97. And lastly I am hoping to find a decent gnarly or fatty pipe out there, but again due to its age I just cant seem to find any.

Share this post


Link to post
Share on other sites

I would say jetting in generally is just off, Are you using the choke to start it? if not it will be very hard to start.

Share this post


Link to post
Share on other sites
I would say jetting in generally is just off, Are you using the choke to start it? if not it will be very hard to start.

Yes using the Choke, I went out and started it this morning, I think the timing is off a little now becasue it kicked back some. Ill pull the cover off and check everything later today. Maybe someone messed with it prior to my ownership and didnt tighten everything back good enough. I dont think its the jetting the bike runs great, and doesnt foul plugs. Actually It has the best looking plugs out of all my bikes, runs a little stronger in the colder temps...I am also going to go ahead and pull and clean the carb, I should have done it as soon as I got it. I really expect that to be the problem, but it ran so good I just never took the time to do it. I dont know if there was old gas in it or just some trash in the tank that has been sucked through. When he brought it over it was bone dry, but that doesnt mean much. Ill keep everyone updated. Thanks for the suggestions

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×