Jump to content
Sign in to follow this  

Inner Clutch Hub Binding. I really want to use my new REKLUSE!

Recommended Posts

Yeah guys and gals,

I have an 01 YZ250. For the life of me, I can not get the center clutch hub to spin freely from the main basket. :bonk: I am running the full rekluse core exp with brand new friction plates and a Wiseco basket.

If i torque the center clutch hub nut down to anything past 20, it will bind... BAD

I have the thrust washers behind the basket and in between the hub and basket. Does any one have any suggestions as to what to check next??

I installed the stock basket (has the main gear removed to use on the wiseco) and that assembly works great. It seems to have something to do with the main ring gear and or basket clearance from the wiseco.

Share this post


Link to post
Share on other sites

I am no clutch pro but it is possible that the bearing race spacer might be to short for your application. I would think it should work but that is really the only thing I could think of that would cause the bind you are describing.

There should be some play in there.

Share this post


Link to post
Share on other sites
a full rekluse core exp has a basket. Why wiseco?

A full rekluse core exp does not come with the main basket, friction plates, or thrust washers. It comes with everything else though...

Share this post


Link to post
Share on other sites

I have flipped the washers over 180 degrees to see if they are one sided. It did not seem to make a difference. Does anyone know the thickness of those washers that I can measure? i would hate to just buy new thrust washers if I didnt need them

Share this post


Link to post
Share on other sites

For my yz 250 97 the thickness for the washer under the the basket ,bottom on is 0.12 in

for the one between both plates is 0.08 in, thicker one goes on the bottom, i belive they are the same not sure.

Share this post


Link to post
Share on other sites

make sure the thrust washer WITH OUT the splines goes behind the basket. Also make sure that it drops all the way into place . There is a very small tapered area that the washer fits over that is small enough to over look.

Share this post


Link to post
Share on other sites

Figured out the problem. I installed a new thrust washer and the inner hub spins freely now from the basket...

I am still having a really hard time getting this rekluse to work properly. Been on the phone with Rekluse a lot now, and can not get the bike to idle in gear or override the clutch completely. I haven't been able to ride for a couple of months now, and starting to develop a very cranking attitude...

Share this post


Link to post
Share on other sites

Found the missing link!! I always update my problem posts just in case anyone else runs into the same problem can find the solution here.

The x-rings or anti squeal rings on the center hub was causing my clutch to drag very badly. As soon as i removed ALL of them, the drag went away! My clutch works as advertised and I can finally ride it this weekend!!!!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×