Jump to content
Sign in to follow this  

Strange rmz 450 issues.

Recommended Posts

Was hoping someonme had heard of this or had this problem before and could point me in the right direction. my 08.5 rmz 450 will start to feel like its going to cut out and then instantly rev out in 3rd gear only. its very strange i have never heard of this before. im a fairly decent mechanic. been working on my bikes and most of my friends for 15 years or so. if the bike is in any gear but 3rd it runs great threw out the powerband. now when in 3rd soon as i get to half throttle and up it starts to feel like its going to cut out for a split second then starts rev out and keeps going back and fourth. sense i pulled the motor to do a top and bottom end. its had some tps issues for some reason but i repaced that. the tps sensor is within oem spec. and the wiring harness doesnt have any breaks in it. any info would be great. thx

Share this post


Link to post
Share on other sites

Check the gear sensor-black box by the shifter. Only other thing could be another sensor or the fuel pump.

Share this post


Link to post
Share on other sites

Thank you. I will check that sensor. This may not apply to all sensors but if that sensor had a problem wouldn't it effect every gear. I got a p.m saying it may be 3rd gear going out. but for some reason i feel its more a electrical issue. That motor was just apart and every gear looked great. the bike has maybe 1OMins on it sense i rebuilt it. thx again

Share this post


Link to post
Share on other sites

The mapping changes via the gear switch for certain gears. I would check the obvious things-grounds,coil,plug,etc.-but since you said it was only related to 3rd gear,that made me think it was the gear sensor.

Share this post


Link to post
Share on other sites

Well I had split the cases. And every gear looks great. The clearance between the shift forks and housing it sits in is all within spec. The forks aren't bent. The gp sensor is diffenitly working properly. Now I'm completely stumped. To recap on the issue. 3rd gear felt like it was spinning really really bad then all of sudden rev out. Every other gear works fine.

Any suggestions.

Share this post


Link to post
Share on other sites

first of all, your 15 years of bike experience trumps mine with bike, so forgive me if youv already done what im about to suggest. if you still have the motor appart, assemble the right hand case completely with the transmission, turn the primary (clutch) shaft and shift through the gears while turning to make sure the tranny is operating properly.

The sensor on the drum may be working, just not switching maps properly (or at all) for each gear, check that the sensors input actuator and pin is not damaged or binding. try working the sensor through its range a couple times, and check the leads and connector for any damaged wires... as stated above check your electrics, otherwise this IS quite odd, and i personally do NOT have experience with this problem, just throwing in my 2 cents

Share this post


Link to post
Share on other sites

Thanks guys, well I did go threw the electrical before splitting the cases. I had ran a trouble code check with the FI light and the 12 volt battery source, and it didn't show a trouble code. And yes I did wait for the 30 sec delay that some Suzuki sensors require. I also checked the gp sensor it was with in spec. I did pull one off the practice bike just in case and it didn't help. I had checked the entire harness for any shorts, or connection issues, if there is something else in the electrical system that I'm missing that would effect 3rd gear only. Cause 1st, 2nd, 4th, 5th run great

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×