Jump to content
Sign in to follow this  

Oversized rotor binding up!

Recommended Posts

So I just bought a Driven oversized rotor and put it on my Crf 250r, for some reason it is rubbing the brake pads kinda hard, I would say a 30 percent drag on the pads when I spin the wheel. I have taken everything off and tried putting the rotor and caliper piece back on it still rubs any one have any ideas, Im lost

Share this post


Link to post
Share on other sites

If it's a constant drag all the way around the rotor then it's a caliper alignment problem. Make sure the slide pins are lubed and the caliper moves side to side smoothly

If it's only dragging in certain places then the mounting on your hub could be warped, or dirt under the rotor, or possibly a warped rotor to begin with.

My rear hub's mounting flag was a little uneven causing my rotor to be out .02" at the braking surface, which was enough to really annoy you. I grabbed some shim stock from work and shimmed the rotor at the hub until it was perfectly straight.

Share this post


Link to post
Share on other sites

Yea it rubs constantly I made sure the caliper can move back and forth I also put grease on the pins when I installed it so it would slid back and forth. LOL I have no idea why its not working properly

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×