Jump to content
Sign in to follow this  

Xr50 wont stay running

Recommended Posts

My 2002 xr 50 wont stay running. It will start now that i cleaned the carb however wont stay running. I am not positive i cleaned the pilot completely. Does this come out? It is much colder here now and i know i need to run a bigger pilot on my ktm. Thanks for any help

Share this post


Link to post
Share on other sites

After being stubborn as hell for the past four months, i finally made the fix for the xr to cure this problem. Its not cleaning out the carb...although this helps and should be done anyway. It isnt re-jetting. It isnt a new air filter.

For some reason the valves have tight tollerances. If they are too tight or too loose, the little buggers dont want to stay running unless really warm. Cant remember what the setting is, but it isnt much, maybe .003 or .004. My compression is a ton better and it starts with the slightest kick. And, it cures what you are talking about and stays running.

This is the fix. Everyone talks about the jets. Once the carb is apart you can blast some cleaner in the holes and see the jets are clean. You absolutely must adjust the valves. It took me four months of trying to clean and adjust fuel and air mixture.

Dont be stubborn and learn from my mistake. VALVES and she will be good.

Edited by jwahrmund

Share this post


Link to post
Share on other sites

I was pumped when it worked and can't believe i didn't just crack the covers open and do it a long time ago. I read about someone else doing this for the fix and thought, "oh heck, that wasn't the problem". well, time to eat some crow...because it was.:smirk:

Now that little sucker is running like a champ and the boy can kick it over with the slightest push on the starter. Not sure that is a good thing. I may come home from work one day and find him ripping up the yard.

Share this post


Link to post
Share on other sites

My '85 wouldn't idle either. Tried a bunch of stuff and finally adjusted the valves. Idles great now, though smokes like crazy out the exhaust again! If it ain't one thing it's another!

Share this post


Link to post
Share on other sites

the lil' 50s are tough. my first bike was a (i think) 70s z50 i got for free that wasnt runing (cleaned carb and it ran pretty good) i rode it all summer long with no air filter and it was still running at the end of it all! i think the carb went form a 16 or so mm to a 10mm it had so much dust built up in the carb. then i gave it to another kid to learn moto ridin' on, dont know how long it kept running tho! that thing was smokn' like crazy. it still started first kick tho, and i never had to adjust the valves. not bad for a 35-40 year old engine!

Edited by MCRIPPPer

Share this post


Link to post
Share on other sites

thanks so much. couldn't get my daughter 2001 xr 50 started after my friends and I ran it one crazy drunk night. cleaned the carb still wouldn't start. did a search and found this thread.  went out in the garage and adjusted the valves. to 003.  put back together. only took five mins.  kicked over started second kick. runs great once again.  thanks once again. 

Share this post


Link to post
Share on other sites

It is the one thing folks on this forum over look.  Like I said before, a kid was basically screaming on here to check valves while all of us well seasoned Dads kept thinking it was the carb.  But, he was right and valves are usually the culprit on these bikes over the carb.  Glad it helped.

 

Good call on the xr50 during drunk night.  I could have been hell if a big bike was involved...and a few more beers.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×