Jump to content
Sign in to follow this  

starter relay - 08 KTM EXCR 530

Recommended Posts

the elec start just stopped working today. the battery is fresh and the bike's really well taken care of. i hear a faint click in the starter relay every time i hit the start button, and one time it made this loud buzzing noise. but it won't turn the bike over at all. wondering if anyone knows what i can do to test if it is in fact the starter relay or something else. thx..

Share this post


Link to post
Share on other sites

Remove and clean battery connections. Chances are one of them (the ground) is loose. The relay is generally reliable, however you can also check the fuse located on it. (if it has one like my '05).

Share this post


Link to post
Share on other sites

yea i checked the connections pretty good and same thing. didn't get into sanding down terminals or anything. i was kinda pressed for time since Sat is the only day i can drop off the bike for service. they've been really good about honoring the warranty, so i didn't want to have to pay for anything if i don't have to. decided to just take it in. plus i've had it in twice for the crankshaft seal issue, so i kinda want a record of anything goin wrong w/ it. i really like the bike, but it definitely comes w/ its fair share of issues. i'm wondering if this relay burnt out because of the cam issue. thought i read the cam was the reason you had to commonly hit the start button twice to turn it over. wondering if that's hard on the relay. anyone have thoughts on this? would like to hear them.. appreciate it..

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×