Jump to content
Sign in to follow this  

Dual Sport America XR400R installation pdf?

Recommended Posts

I bought a dual sport kit from them in August for my 97 XR400R and it took almost 3 months to have all the parts delivered. Despite numerous attempts asking the owner for the installation manual pdf he would not deliver it. I even filled a report with the seller's BBB with out any remedy. Has anyone out there had a similar experience but actually has the pdf to share with me?

Thanks!

Share this post


Link to post
Share on other sites

You may want to do a quick search in the D/S section of the forum. It seems like I remember reading similar posts about the lack of customer service from them.

Share this post


Link to post
Share on other sites

I got one from them a couple years ago. I don't have the directions anymore but I could take a look at my bike if you have any questions.

I did'nt have any problems with them, but there have been many posts on here from people with the same issues as you. I was one of the lucky ones. Let me know if you have any questions.

Share this post


Link to post
Share on other sites

Thanks Michigan400. That guy DSA is a real piece of work. I have the system where a small lithium battery runs the turn signals and horn. I have that working fine along with the lo/hi beam on the headlight (which powers off the stator with the bike running).

My problem is getting the tail light and brake light to work. I have a WPS tail light from Procycle that has a black, red and white/black striped wire coming out. Also an LED plate light with a black and red wire.

http://www.procycle.us/dskits/dskit.htm

The DSA system has yellow, red and black wire coming out of the harness. I need to know which color goes where. Right now I have yellow-to-striped, red-to-red and black-to-a ground wire to the frame itself.

Thanks!

Share this post


Link to post
Share on other sites
Thanks Michigan400. That guy DSA is a real piece of work. I have the system where a small lithium battery runs the turn signals and horn. I have that working fine along with the lo/hi beam on the headlight (which powers off the stator with the bike running).

My problem is getting the tail light and brake light to work. I have a WPS tail light from Procycle that has a black, red and white/black striped wire coming out. Also an LED plate light with a black and red wire.

http://www.procycle.us/dskits/dskit.htm

The DSA system has yellow, red and black wire coming out of the harness. I need to know which color goes where. Right now I have yellow-to-striped, red-to-red and black-to-a ground wire to the frame itself.

Thanks!

I have a different kit on my XR4 with no battery but I'll take a look when I get home and see whats there. I think I just tapped in to the stock tail light power supply under the seat with the tail light/plate light and the brake light from the swiitch on the pedal. I'll post back later with what I actually see.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×