Jump to content
Sign in to follow this  

85' klr 250 cam help !!!

Recommended Posts

OK... So I just bought this low miles klr 250 (5800) and the owner said it has a bad exhaust cam? I test rode it and it seemed to ride ok but it also was a bit anemic. Don't know if it was because of the cam. Can anyone help with diagnosing? Should I take his work for it about the cam? Is there any tests I can do to see if it may be something else all together? If it does need a cam I was thinking of just taking both cams out and have them refaced by megacycle. Any help would be greatly appreciated.!:smirk:

Share this post


Link to post
Share on other sites

I would pull the valve cover off and take a look at the cams. It's easy to do, it even has a rubber gasket so you won't have to get a new one. You could check the valve clearances while you're at it. If the cam is scored that could be why it isn't running right.

Share this post


Link to post
Share on other sites

I also agree with McDuff, take off the valve cover and check things out.

Also, if the cam is bad; chances are that the rocker arm has probably crapped the bed too. So order them both. Does it burn any oil? If so, maybe start looking into refreshing the top end.

Share this post


Link to post
Share on other sites

Thanks for the input Mcduff and Nono443. I am currently geting a midgrade refacing from megacycle cams as we speak. The dealer tech said to get a cam chain tensioner replaced also. I trusted his opinion so i'm waiting for that part now. Does anyone know of an aftermarket rear spring upgrade for this bike. Any ideas would really be appreciated. Thanks. :bonk:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×