Jump to content
Sign in to follow this  

help me on my couple first fix-its on the 625smc

Recommended Posts

bike runs decently... i'm hoping the first issue is b/c it's cold. the second, i'm simply not familiar with the KTM just yet, so a little point in the right directly would be greatly appreciated.

1. start the bike, let it idle for a bit (~2 minutes), then head out around the block. cruises for a bit, then when i romp on it it stutters and THEN kicks in. thoughts? could it just still be cold? if so, that's easy... if not, where should i start looking?

2. the rear caliper is holding the rear pads ON the rotor - as in, i can smell them getting burned up after a quick run around the block... i have a feeling this has something to do with the new caliper installed after the bike got blown over by wind and insurance replaced it b/c of a scuff. brand new pads, just wonder if the reservoir is too full or what. simple enough... i hope.

thoughts?

Share this post


Link to post
Share on other sites

I have limited experience with a 625 and 640, It seems they need a little more warm up than my suzuki or honda. Warm up a little more before taking off an leave the choke on a lttile bit for a ways.

Don't know about the brake. Maybe spray a little wd40 on the piston to get it to slide better. I always spray it on before pushing the piston back in. I dont know if this is what you are supposed to do but it prevents wrecking the piston.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×