Jump to content
Sign in to follow this  

Odd Jetting issue

Recommended Posts

wanted to do the jetting mods to my ttr125. so i went to my dealer to get bigger jets and they only had the main jets in stock. i went with a 115 because i got the wiseco high compression piston, spark arrestor off (soon to be a custom real high flow muffler ill make usin the stock one, needle moved to middle, then a custom air filter. for whatever reason when i installed the new 115 main its still runnin real nice when its in low to mid rpm its runnin nice and strong. once it starts gettin revved it starts spittin and studderin and really wont rev anymore. the carb is gettin fuel but it seems like it isnt. also i did a plug test and the plug is grey at full throttle. also 1/4 is lean too. i know your supposed to use a new plug everytime for the test but i could tell the plug difference each run. i havent put the stock jet in but it was runnin ok b4 i put the 115 in. i never did a plug readin with the old jet. but why would i have a lean issue if i go to a larger jet size? obviously the pilot is too lean. could that affect it?

Share this post


Link to post
Share on other sites

Main Jet is ONLY used at 3/4 throttle and above... otherwise, below that you're carb is just spitting through pilot and needle.

So, having replaced the main and you have problems at 3/4 throttle and above, it makes sense that the main is not setup properly for your other variables.

http://www.4strokes.com/tech/howtojet.asp

Share this post


Link to post
Share on other sites

Did you get a mikuni big jet? They have the larger head than a normal mikuni head. Without the larger head that white washer looking thing that sits with the main jet wont seat correct and give you all sorts of problems

Share this post


Link to post
Share on other sites

After you confirm that you have the correct jet series, run it again on the top end with the choke pulled out, and see if it is better or worse.

I suspect that you are way too rich. A high compression piston often requires a leaner main, since the engine is now a more efficient air pump and is pulling more fuel through the same jet.

Share this post


Link to post
Share on other sites

the jets are identical other than the hole. i did a choked run and it looked to be turning brown. i think im gonna wait till i finish my exhaust to do the final tuning cause now if i tried anything it would be without a muffler. im gonna i think do a 1 3/4" core straight thru and put fiberglass muffler pack around it just like the big 4 stroke pipes. havin a machine shop at my disposal is nice. do any of you guys know that the pinkish white thing does with the 4 holes. i tried a run with it out and it didnt seem to make any difference.

Share this post


Link to post
Share on other sites

Try dropping down to a 112 or 110 main, sounds like it's too rich. It's pretty tough to get an accurate plug reading with today's gas. Look at the outer ring on the plug [not the electrode] if it's black, it's a good indication your too rich.

Share this post


Link to post
Share on other sites

alright. im gonna be orderin a bunch of parts for it gettin it ready to possibly sell so ill order it then. ive got a few friends wantin a bike. plus my friend told me hes got a buddy whos sellin a banshee for 1grand. said hes sellin it cause he has ms and cant ride anymore. im not really a quad guy but ive always wanted to own a banshee. im gonna hate to see this fun lil bike go.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×