Jump to content
Sign in to follow this  

ttr wont fire

Recommended Posts

ok guys....my buddies ttr125l wont fire...we took the carb apart because the people that had it before let the fuel sit in it for a yror so...carb was really bad...we cleaned it and put everything back the way it was and now it wont fire....theres spark and its getting fuel...any suggestions ?

Note...we did take the carb apart earlier and cleaned it and it did run...it ran like crap...only quarter throttle....i figured the jets were still junked up...so we took it apart again an it was junked again...but now...it wont fire at all...id really appreciate any help i can get with this....thanks again guys

Share this post


Link to post
Share on other sites

sumthin i do is to make sure the jets are clean get a carb or brake cleaner can that comes with the little red straw. its literally perfect size to go into hole on the flat head side of the jet. then i just spray some thru it. if its clogged id spreay it pretty good to make sure the gunk is out. also watch where you aim it cause ive had it shoot carb cleaner like 15ft from sprayin through the main jet. haha. if you cant get the carb cleaner to even flow thru it may just be easier to go out and spend a few bucks on new jets. maybe get the bigger jets they recommend on here.

Share this post


Link to post
Share on other sites

yeah did all of that...got it to start then after it wouldnt clear out took it apart and did the same thing and now it wont fire...it would rev like it was all cleared out then when you take off it would sputter an run like crap...any suggestions >?

Share this post


Link to post
Share on other sites

You can't clean the pilot jet. Buy a new one. A 17.5. The little fuel tube at the bottom of the choke plunger passage that draws fuel up to enrich the mixture for starting is probably plugged also.

Share this post


Link to post
Share on other sites

You can't clean the pilot jet. Buy a new one. A 17.5. The little fuel tube at the bottom of the choke plunger passage that draws fuel up to enrich the mixture for starting is probably plugged also.

i would totally agree with this. ive never really been able to get a dirty pilot 100% again.

Share this post


Link to post
Share on other sites

Mine is doing similar things. The carb was dirty and it woul not start. It runs now but it stutters. Air filter is clean, new plug, I cleaned out the tank completely, I put on an in line filter and I can see through the pilot jet. Did you get your bike to run? What did it take?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×