Jump to content
Sign in to follow this  

yz250f wont turn over

Recommended Posts

i have a 08 yz250f that was running fine but since its winter i started rebuilding the top end. but now the problem is that when i have the cams lined up perfectly with the piston at top dead center and ill start turning it over and once it gets to a certain point it just stops, sounds like the piston is hitting a valve? does anyone know what the problem is here? how to solve this? thanks

Share this post


Link to post
Share on other sites

Yea triple check your timing with your cam chain tensioner installed and working. and also make sure its in neutral.

Share this post


Link to post
Share on other sites

i have quadruple checked the timing and yes the cam chain tensioner was on when turning it over thats why i am still so confused on whats wrong..... im going to check valve clearences on it tomorrow. Anymore suggestion let me know thanks

Share this post


Link to post
Share on other sites

Did you change and shims or do something that would make valve piston clearance close up? Did you install a high compression piston? If so, give specs. Also, I'm curious what the position of the piston and crank are. I'd remove the left side cover and look at the timing marks vs where the crank is. Another way is to remove the spark plug and put a long probe (pencil or welding rod) and see if the piston is moving at TDC or what. I've also seen motors put together with the incorrect head gasket and the piston hits the head. Did you use and OEM head gasket? Just trying to get complete info.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×