Jump to content
Sign in to follow this  

05 rmz 450 smokes on start up

Recommended Posts

My 05 rmz smokes on start up when it's cold. It has a fresh top end new valve piston rings and piston. New timing chain and guides. When I assembled the motor I oiled the piston and piston rings I was told that I should not have done this. From what I understand the piston rings do not seat correctly. Does this sound right or is it a myth? Any help on this would be great. Thanks

Share this post


Link to post
Share on other sites

Shouldnt be a problem from oiling the piston. Did you replace the valve seals as well? Usually smoking only on start up is a tell of bad valve seals.

Share this post


Link to post
Share on other sites

If you're confident about your build and tolerances give it about 10-12 hours. Don't rap the throttle during warm up! Let it warm up with just the choke. Takes a while for things to seat in. Hopefully you're not using synthetic for break-in? Keep an eye on cam chain adjustment during break-in. I think building an engine dry without lube or assembly lube is nuts!

Share this post


Link to post
Share on other sites

I def agree with you with no oil on rebuild. I am confident on rebuild and tol. I took my time and followed the man. to a T. Thanks for your help I guess I will give it some time before i tear it back down.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×
×
  • Create New...