Jump to content
Sign in to follow this  

2007 idle and backfire?

Recommended Posts

I just got a 07 kx250f and it won't idle very well. Also is has a very loud backfire on decel. It has a white bros carbon pro exhaust on it. Looking at the spark plug it seems to be rich. Do I need to change the jetting? The main jet is a 186, the clip is on the third notch down, and the pilot jet is a 42. Any help would be greatly appreciated.

Share this post


Link to post
Share on other sites

With the after market exhaust you should install a JD jet kit. The backfire on decel means its running lean.I have an 07 kx250f with a FMF mega bomb exhaust .Tried a fmf jet kit didnt like it The JD kit worked sweet.

Share this post


Link to post
Share on other sites

First you should make absolutely sure that the aftermarket exhaust has no leaks. Especially the copper crush gasket between cylinder head and exhaust header pipe. If it leaks, it will pop like crazy, no matter what the jetting is. Also make sure the hotstart plunger closes completely.

Share this post


Link to post
Share on other sites

I dont know too much about these bikes yet... BUT:

I got two 07' kxf250's a month ago and one backfired a bunch on decel. After researching here i decided to increase the size of the pilot (slow) jet. This was a super easy job and a super cheap part which completly fixed my problem. I went up one size from the stock 42 (47 maybe? i cant quite recall, certainly no bigger than that) i swapped stock #40 pilot jet on bike A for a #42. I live in texas... i hear that is important to consider the a/f ratio.

If you dont know, you can get to this guy buy just rotating the carb sideways and taking the bowl off the bottom... its a simply screwdriver to remove and install new one.

Edited by Ibanezsvo

Share this post


Link to post
Share on other sites

My 08 would backfire like crazy in gear and in neutral, and sometimes a flame will come out or two. I had a 42 pilot jet in their and put a 45 pilot in their and I have a 186 main in their now with my fuel screw turned one time I think--solved my problem, doesn't backfire only a little in neutral if that (haven't rode in a while). I have a fmf powerbomb and ti powercore for exhaust

Share this post


Link to post
Share on other sites

Thanks for the help I think I'm gonna bump up the pilot jet one size and see if that helps.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×
×
  • Create New...