Jump to content
Sign in to follow this  

installed the new carb on my drz-sm today... but

Recommended Posts

Installed the carburetor I bought last week (BSR 36 CV). Was off a '09 model, but in exremely good condition and completely stock.

I have a JD Jetting kit and installed that, same set up as the old carb I just replaced. Set up is for TRC full exhaust, 3X3 mod and UNI airfilter. Jet kit is blue needle on 4th clip, 160 main jet, 22.5 pilot jet and Keintech screw at 3 turns out (as per JD Jetting email). Took apart the new carb and made sure everything was extremely clean. Bolted everything back together. Once I had the fuel tank on and fuel line on, fired it up. Started up first stab at the starter button and was pretty much spot on idle after it fully warmed up (was maybe a tick over 1700, so brought down to about 1500 ish). Rode around and checked to make sure no fuel leaks... all good to go there. Progressively riding more brisk is when I noticed what I didn't experience before... in pretty much all gears, if I slowly and smoothly go up to near redline... between the start around 6500rpm to 8500 rpm, the bike kinda stutters/acts abrupt a bit until like 9000 to redline OR if I fully open the throttle. If I just wack on it through the gears, I don't notice it of course... but slowly and smoothly up to those rpm ranges, it acts kinda poorly. I adjusted the Keintech screw from 3 turns out to 3 1/2 turns out... no change. So, turned it back and then turned in to 2 1/2 turns... no change. Spark plug is new, air filter is new. Gas is brand new and fuel filter is new as well.

I haven't taken the carb off yet to go through it, but anyone have a suggestion to what might be causing this? Or what I may need to try internally wise??

Im at 1400ft elevation here in Arizona too.

Edited by Arizona_SuMo

Share this post


Link to post
Share on other sites

Adjusting the fuel screw wont affect anything except idle mixture.

What throttle position are you experiencing this stutter at? It almost sounds to me like the pilot jet is too lean, try a 25 or 27.5 pilot see if that helps. The pilot has an effect at 1/8 throttle and it almost sounds like thats what youre doing by accelrating smoothly? you shoudlnt be accelrating slowly at 9000rpm anyways, You should be WOT!

Edited by crxdan

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×
×
  • Create New...