Jump to content
Sign in to follow this  

2010 COLD Clutch slipping!

Recommended Posts

I have a 2010 250r and it has aprox 45 hrs on it. Around hour 35 i started to experience clutch slipping issues. The weird thing is, is that it only slips when its cold. Once I ride around the track a lap or so there is no longer a issue. When its hot it grabs fine, when its cold slips like crazy. Anyone else have this problem or know of a solution? Oh and removed the clutch from the bike and all the fiber plates look good, steel plates aren't smoked and also tried replacing the springs and still does it.

Share this post


Link to post
Share on other sites

at 45 HRs its time to think about replacing your clutch plates or else this can happen. everything looked good 2 except these 2 clutch fibers

this was my brothers '10 crf250 clutch that i replaced for him

same symtons you are facing, not grabbing when cold.. it was hard to pull to (obviously), they may look good but stock clutches get weak easily.

i threw the Hinson replacement clutch in there and let it warm up good and its better than its ever been.

420600_2963340676623_1054793403_33045792_157522210_n.jpg

Edited by AJMAG247

Share this post


Link to post
Share on other sites

Both my 2010 and 11 slipped a little when cold but grapped when it got hot ,i think its normal

at 45 hours i think it must be time for new plates though

Kim

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×
×
  • Create New...