Jump to content
Sign in to follow this  

dr650

Recommended Posts

my 1996 Suzuki dr 650 has a real bad gag in it. it stars fine and i can ride it normally but when i trie to go throw the gear at a faster rate it starts firering back and gaging

Share this post


Link to post
Share on other sites

Has it been sitting for a while? Did this come on slowly or all of the sudden? Could be a clogged jet. Give us more info to work with.

CoKTM

Share this post


Link to post
Share on other sites

it was sitting for a long time and we had it running good at on point then i had to take it apart because i need to order a new petcock and then i started it and it had a gag so i thought there was something in the jets so i got them cleaned and got new sparked plugs ran great for 3 days thought it was fixed but 3 days later it cam back

Share this post


Link to post
Share on other sites

Sounds to me like it is probably the jets again. When a bike sits for a long time varnish builds up in the fuel system. The inside of the tank can also rust if it is a steel tank. Either of these things can continue to clog jets until the fuel system is flushed.

CoKTM

Edited by coktm

Share this post


Link to post
Share on other sites

theirs a filter so it filters all the gas that comes out of the tank and i had the carb cleaned and looked at by a carb mechanic he checked all the jets and checked everything out he thinks it has something to do with ignition

Share this post


Link to post
Share on other sites

Do you know about the little filter at the metal Carb inlet tube? There is a tiny white plastic filter there. Might be clogged up. It's located in the metal fuel tube that goes into the carb. You can just see the

end of it. Pry it out ... carefully.

Things to do:

1. remove fuel tank, clean and flush out. (Do This OUTSIDE!)

2. Pull petcock out of tank ... carefully clean filter screens with tooth brush.

3. Buy a NEW Pilot Jet. It's most likely clogged. Cheap fix.

4. Plugs should be fine ... no need to replace unless they have over 12K miles on them. They will clean up once bike is running well.

If jetting, air box and exhaust are ALL stock, then once cleaned up the bike should start, idle and run fine. If not stock ... then other issues could be at work.

Good luck!

Edited by 54321

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×
×
  • Create New...