Jump to content
Sign in to follow this  

Any Advice is Appreciated

Recommended Posts

I recently purchased a stk 05 klx 110. Upon purchase i quickly realized in need a carb clean, after removing the carb to soak it over night, i replaced the float needle as well as the main and pilot jet, a process ive performed with no trouble on various other 250f's. I also replaced the throttle cable and got everything back together. After toping it off with some fresh gas I went to start it. It started 3rd kick with the choke and idled fine once i took it off. However when i rev the bike in neutral it seems to skip and spit, almost like water is in the fuel. I took everything back apart made sure I hadent over looked something, and everything was in order. Again once back together the unit started fine, but continuted to spit and not rev up like it should. I rode it around the yard and thourghout all the gears it spit and not rev out. Also the bike does not pull very well. Any ideas?

Note: piror to cleaning the carb the bike ran ok. better than it does not..though i had to nurse it up to speed in each gear, once i was on top it seemed to run like a champ.

Share this post


Link to post
Share on other sites

Did someone mess with the carb before you bought it? Maybe the reason they sold it is because they messed with it and couldn't get it running right. I mean, you can buy a stock carb on eBay or planetminis for $20, should almost pick one of those up, slap it on and see what happens...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×
×
  • Create New...