Jump to content
Sign in to follow this  

08 rm85 not top end power

Recommended Posts

my son was riding his rm85 yesterday then came to me saying it

doesn't rev like it used to but idles fine.i pulled the plug and found

it was fouled so i put a new one in and got the same results cleaned

the carb didn't help.

i'm new to 2 strokes and don't know where to go next.

thanks Brian

Edited by docholaday67

Share this post


Link to post
Share on other sites

the only thing i didn't check was the reed valves. i would assume

they are between the carb and the cylinder.i have also read on

here that the power valve may be the problem but know nothing

about them. is the power valve located just above the header pipe?

Share this post


Link to post
Share on other sites

Power valve could be carbon up and sticking, or the only other thing that can happen is the bolt (behind the right cover, will need to remove the pipe to get to the cover) has back out and the linkage has came loose.

A realy dirty air filter is the number one cause that will kill the RM85 top end power also.

Share this post


Link to post
Share on other sites

The bike will not run correctly with out the air filter or the silencer.

If she is starting and running, then chasing the wiring won't help your problem.

Do check the power valve system for loose linkage bolt and carbon up power valve.

May just need some fine tuning on the jetting to get it running clean in the winter weather.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×
×
  • Create New...