Accelerator pump not working?

I just did the BK mod to my carb on my 02 yz426 and when i went to tune it in, the pump wasn't squirting fuel at all. i pulled the whole carb apart and made sure to the best of my abilities that all the passage ways were clean. Tried it again and still nothing even after warming the bike up and making sure the float was full and everything. I don't know if this was an existing problem or if it was something i did in the process because the bike runs great besides a little throttle bog before i did this. Thanks for any information it is much appreciated.

Be sure that:

  • The spring is on the bottom pushing up toward the rod
  • The diaphragm is not torn or perforated
  • The diaphragm is right side up
  • Both the inlet and outlet check valves are working
  • All the passageways are clear

Then be sure your adjustments of the timing screw and the stop limit screw that you added aren't such that they prevent the pump rod from moving the diaphragm

i have this same problem my acc pump doesnt work either not sure why, ive checked everything twice and mine is stock. post up if you figure it out

i rechecked all the passage ways and made sure they were all clear and i had to buy a new diaphragm cause you could see through half of the old one, and it wasn't making any suction. i cant wait to get my suspension back and on the bike and see how it runs. it has to be a night and day difference from not having an acc pump to having a modded one! Thanks gray

one more question for you. should i run the o ring mod for the acc pump along with the BK mod or just BK mod?

Just the BK.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now