GYTR tuner issues

If I press the power button on my tuner without it plugged into the Bike, it comes on fine and I can create maps and whatnot. But, when I plug it in and press the power button nothing happens. It Will not turn on at all.

Any ideas?

Try changing batteries, I had same problem with mine if I remember right. I put in some new batteries an problem went away,

Batteries, for sure. Happened to me also.

I barely use fast does the thing eat batteries?

you should take the batteries out when in storage or the "batteries will eat the thing"

I had the same issue as well, the tuner needs fresh batteries when connected to the bike.

However, you can still use the tuner with the bike without batteries if the bike is running, as the bike will power the tuner when it's running. With the bike running though, you cannot upload any adjustments and can only monitor vitals of the engine.

I'm having a problem with my tuner, I've had the bike for over a year and haven't even opened the tuner box, i put some batteries in it and it fires up fine when its plugged in, than when i go to monitor it says cannot connect to the ecu, same thing when i try and load a map to the ecu. anyone have similar problems?

Same here swapped batteries with a fresh new set and it worked fine. Definately needs batteries that are nearly full and not run down at all.

Directions recommend using freshly charged nimh batts NOT alkaline.

Directions recommend using freshly charged nimh batts NOT alkaline.

When I read that, I jump to the conclusion that the tuner draws a fairly high average current. Probably as a result of powering up the bike's system when it's plugged in. Interesting.

yeah i read that and figured the same thing, although everyone i have spoken to about the tuner uses regular duracels. ill try some brand new freshies than if that works ill go and buy some nicad rechargeable.

I'll try some brand new freshies than if that works ill go and buy some nicad rechargeable.

Nickel Metal-Hydride, (NiMh) NOT NiCads. NiCads are junk. They don't deliver the energy of a good alkaline and they have memory problems if you short cycle them.

I was having the same problem with my tuner as well but found a work around. Plug the tuner into the bike, start bike (automatically powers up the tuner), do any monitoring you want with bike running (idle, temp etc.), turn bike off (tuner will stay on), transfer maps etc as you normally would with tuner on and bike off, power down tuner and disconnect.

i tried new alkali batteries, no go. i tried nimh rechargeables, no go. i tried plugging it in, starting the bike, still... "failure to connect to the ecu." so my next step would be looking for any loose connections right? also i have a vortex ignition box, will that mess me up?

when i open up the settings tab the tuner lets me edit maps and such but will not allow communication between the ecu and the tuner. same in monitor mode. so seems to me like the coupler is not fully connected tot he ecu or wiring harness. not too sure how all that looks seeing as I'm not to savvy witht he electrical system of the bike... or any electrical system for that matter, but i do know that if something isn't securely plugged in... it won't work (duh!) lol. I'm tearing the bike down to do a top end here next week ill check it all than. but any other ideas as to whats wrong would be greatly appreciated...



Just a guess, but I bet the yamaha tuner is NOT compatible with the Vortex ignition. Doesnt the virtex have its own built in non changeable mas?

It would not work with a Vortex. The Vortex kit costs about $800. If you want something done to the Vortex you could send it to a place like Tokyo Mods for reprogramming.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now