Jump to content
Sign in to follow this  

ts90 smoking badly, running rich

Recommended Posts

hi guys, I have a 1970 suzuki ts90, it smokes like a mofo and runs rich, i have the needle on the lowest setting, the gas is mixed at 50:1 and the oil injection is removed. could i have a bad clutch side crank seal?

Share this post


Link to post
Share on other sites

leaking crank seals make ir run lean not rich. The oil injection is very important to remain connected as it supplies oil to the crank bearings. Do not run it on pre mix. could be low compression.

Share this post


Link to post
Share on other sites

definately not low comp. thing tested at 186 psi, i need to hook the oil injector up then eh? i thought it was a bad clutch side seal because of the oil it would be sucking

Share this post


Link to post
Share on other sites

I second hooking the oil injection system up. There is no reason to premix unless the oil system was giving you problems. How are the float levels? Does your carb have the stock jets in it? How does the plug look?

Share this post


Link to post
Share on other sites

hi guys, I have a 1970 suzuki ts90, it smokes like a mofo and runs rich, i have the needle on the lowest setting, the gas is mixed at 50:1 and the oil injection is removed. could i have a bad clutch side crank seal?

my brother had an mx 175 with a leaking right side crank seal it ran away and ran lean sometimes but most times it ran ok and just smoked really bad especially right on start up

Share this post


Link to post
Share on other sites

oops, tore down the bowl of the carb, so much jb weld in there, f*** now i have to pay 20$ for a carb kit, oh well I got the bike for free

Share this post


Link to post
Share on other sites

oops, tore down the bowl of the carb, so much jb weld in there, f*** now i have to pay 20$ for a carb kit, oh well I got the bike for free

lol nice could be the issue but maybe not, i had to jb weld my brothers carb on his kdx to see if it ran there was a hole straight through the drain bolt but i only used a little bit

Share this post


Link to post
Share on other sites

I raced MX on a 100cc gyt kitted TS back in 71-72, taking the oil pump off was a must do for rough riding back then, the oil would bounce around in the oil tank and you could see air in the oil lines. Dusty conditions could clog the vent hole on the oil cap. After blowing a couple of cranks I removed the oil pump and the oil catcher on the crank and ran premix. Never blew another crank after that. The 100cc kit came with the plate to cover the hole where the pump was if I remeber correctly......

Share this post


Link to post
Share on other sites

If you keep a decent amount of oil in the tank I don't see how it's possible to get air in the lines unless your run it upside down for a few minutes. I've had 3 bikes with premix pumps and have never had problems with air in the lines or going through cranks. If it's adjusted right and primed correctly you will not have any problems, it will smoke less, and you don't have to worry about mixing gas.

Edited by 79yamdt

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×
×
  • Create New...