Jump to content
Sign in to follow this  

Throttle cables pinched/cut

Recommended Posts

***** EDIT...... I MEANT THE CLUTCH/DECOMP CABLES ARE PINCHED, not the throttle*******

I have the BRP Triple Clamp and Scotts Sub mount on my XR650R. The cables are getting piched between the clamps and the forward stabilizer pin mount when the bars are turned to the right in full lock (mainly when plowing the front end into the earth). This setup was on the bike when I bought it and I do not know if extended throttle cables where installed. From looking at it, longer cables or not, it just seems there is no way to avoid the pinch point as this is the proper routing.

Anyone run into this? I know my problem is the occasional digger but replacing cables will get old. I like the stand off bracket Scotts sells to keep the throttle cables from snagging the stabilizer and wish there was something to save my throttle cables.

Edited by Mescalero

Share this post


Link to post
Share on other sites

Terrycable.com will make anything! Give them call!

Edited by bork

Share this post


Link to post
Share on other sites

***** EDIT...... I MEANT THE CLUTCH/DECOMP CABLES ARE PINCHED, not the throttle*******

I have the BRP Triple Clamp and Scotts Sub mount on my XR650R. The cables are getting piched between the clamps and the forward stabilizer pin mount when the bars are turned to the right in full lock (mainly when plowing the front end into the earth). This setup was on the bike when I bought it and I do not know if extended throttle cables where installed. From looking at it, longer cables or not, it just seems there is no way to avoid the pinch point as this is the proper routing.

Anyone run into this? I know my problem is the occasional digger but replacing cables will get old. I like the stand off bracket Scotts sells to keep the throttle cables from snagging the stabilizer and wish there was something to save my throttle cables.

I've got the same set up as you if I understood your description correctly. My clutch and decompression cable don't go in the front of the bars, they come off the back of the bars and then along side fram underneath the tank. Pull them off your clutch perch and reroute them so everything works.

Share this post


Link to post
Share on other sites

I've got the same set up as you if I understood your description correctly. My clutch and decompression cable don't go in the front of the bars, they come off the back of the bars and then along side fram underneath the tank. Pull them off your clutch perch and reroute them so everything works.

Here is a link to the instructions so you can see what we suggest for cable routing. Keep in mind if it has really tall bars as well as the sSUB mount you may still have issues

http://www.scottsonline.com/litrack/273.pdf

Thanks-

Eric

Share this post


Link to post
Share on other sites

Crap..... It looks like they were routed wrong. I figured it was correct since the installer/owner was a pro. Thanks for the link to the pics pb1963.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×
×
  • Create New...