Jump to content
Sign in to follow this  

07 bog and backfire

Recommended Posts

I am having trouble with my 07 kx250f. It starts up well and idles ok. Wen I rev it it bogs on bottom

But is good after that. It also pops on decel but after it get hot it seems to be a little better. Any help would be greatly appreciated. Thanks

Share this post


Link to post
Share on other sites

I had problems with my bike and i tried going up on the pilot jet. It fixed my backfire on decel, but not my bog. Someone on here suggested that I do the AP mod, which is when you zip tie the AP diagram together in the carb..easy fix and solved my problem

Share this post


Link to post
Share on other sites

Mine has the same problem I think the fix is

move needle clip down 2 notches

run stock pilot

180 on the main

that will fix it

Share this post


Link to post
Share on other sites

Stock pilot will never work. Especially not in the winter.

Needle clip position has nothing to do with bogging when twisting it from idle.

On older bikes the accelerator pump (AP) diaphragm could be shot. Inspect/replace it. Also the passages through this circuit must be clean.

Wiring the AP link may help, but the linkage should not be hanging up to begin with. Sometimes they get grimey and sticky and need cleaning to move freely.

Also, the return spring could be old and tired. There are aftermarket heavier springs available that do the same thing as the AP mod.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×
×
  • Create New...