Jump to content
Sign in to follow this  

08 450 EXCR under fender problem (main fender mount broke off), looking for ideas

Recommended Posts

I noticed the other day that one of the two mounts for the under fender I have broke off and I'm trying to figure out a way to fix it without having to drill through the orange main fender and having parts show or replacing it. I'm not sure of a clean way to fix this without making it look crappy!

At worst I'd get some nice stainless steel hex flat head bolt with a finish washer for the top side and some kind of washer stack and nylock or tee nut for underneath. I used similar hardware for my license plate.

I'm guessing that the mounting boss on the orange part must have been more protected with the original under fender and the aftermarket one really exposes them. The terrain where we ride is very mixed and no shortage of fist sized sharp rocks, which I'm guessing got whipped through there and took it off.

http://s821.photobuc...under%20fender/

IMG_0249.jpg

It looks like the design of the new under fender just leave the original mount points far too exposed. I had also put split loom on all of the wiring and it took that off too.

IMG_0250.jpg

I'd rather not drill through the orange part, but also don't want to buy a new one either! I'm guessing I'll use the same license plate hardware to fix it. I need to prevent this from happening to the other side though.

IMG_0256.jpg

Edited by helix66

Share this post


Link to post
Share on other sites

That mounting method and the wires are MickyMouse hanging down like that.

At a minimum you need to eliminate that big spacer and use some cable guides so more damage isn't done.

I used aerosol expanding insulating foam to bond the two pieces together, careful really messy stuff. My mounts were fine but the flex/give between the parts allowed the fender to flop up and down nearly eating one license plate. Doing this made the whole assembly easily twice as rigid.

The parts need to be clean to bond and once done you may never get them apart again (I don't go through plastic). The foam is light and fill gaps keeping mud out. Perhaps another bonding substance (a bead of silicone?) would work better for you .

Bruce

Share this post


Link to post
Share on other sites

yes, I agree that the entire mounting method is poorly designed. I put on the split loom and zip ties to hold it, the under fender comes without any of that! The way it is now the license plate won't get sucked into the tire like the oem but this is an unforseen issue. And I'm not totally following how you used the expandable spray foam. If you could post a pic that would be great.

Are you suggesting to glue the under fender to the upper orange one? I'm not into doing something that would be permanent, it'll definitely become a problem later on, and I really hate using that stuff. Silicone would be better since it could be pulled apart, or if you wanted permanent I'd go with PL adhesive.

Share this post


Link to post
Share on other sites
Are you suggesting to glue the under fender to the upper orange one? I'm not into doing something that would be permanent, it'll definitely become a problem later on, and I really hate using that stuff. Silicone would be better since it could be pulled apart, or if you wanted permanent I'd go with PL adhesive.

Yup, not for everyone but 04 EXC and 05 CRF each with 7500 mostly offroad miles and no problems but as I said still OEM plastic. The KTM under fender only mounts in 4 locations, sufficient to keep it on but not to prevent flex. Playing with it I could see that when flexing the 2 pieces were in shear, bonding them together fixed what had been a bigger problem.

Sounds like you will be drilling holes and using fender washers then.

Bruce

Share this post


Link to post
Share on other sites

Ya, I'm not gluing any of that, when you do that and have an electrical problem and a buried connection! I got some nice stainless hardware and finish washers, should look ok-ish!

It's not the oem under fender, it's the one from sicass racing which is designed to not get sucked into the tire, it's just not the best thought out design in my mind though. I might have been better off getting the ktm 6-day part, but that tail light is pretty weak compared to the aftermarket led on mine......all moot if it doesn't stay on!

Share this post


Link to post
Share on other sites

As crued as it is I drilled a small hole through my fender. Put a small button head bolt with a large washer on both sides and a nut on the underside. Never broke again.

Oh, painted the bolt orange for the top side so you really never even saw it. Figured if it ever gave up I would just buy another rear fender and under mount from SicAss racing again. They had the best price if you buy the whole assembly (fender, under mount, LED tail light). It wasn't on their web sight but if you call them they have it. Damn near as cheap as the fender by it's self from the dealer.

Share this post


Link to post
Share on other sites

I'll put up a pic of my fix, I got a flat head socket screw and a finish washer, underneath a stainless nylock and big washer, all stainless. I just didn't want it to look janky! I still think it could be designed better. 21-188.gif

Share this post


Link to post
Share on other sites

Done. The top is ok, the bottom so-so. I might block it off with a piece of plastic to cover the wires.

IMG_0257a.jpg

IMG_0259.jpg

Share this post


Link to post
Share on other sites

Thanks, I just used pliers, wish I had a vise though! The one came out good the other I bent a bit too much, I'll never notice it!

The guys at sicass were thinking that my suspension bottomed out and grabbed the one mount, seems to make sense.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×
×
  • Create New...