Jump to content
Sign in to follow this  

Dead battery and FCR related question, I think.

Recommended Posts

I did a search and could not find anything related to this so if I missed it please direct me. I installed stage 1 hot cams, and an fcr, FMF to be replaced with the MRD in the morning with eddies specs on my SM. It take a few seconds to turn over now but it will eventually start and idle fine after it is warmed up all the way. Once it gets going it runs great. My issue is that it takes so long to start the bike that it has killed my 6 month old battery. Is there anything I should do or check? Is there a better battery than a normal OEM replacement I should try?

Thanks,

Chris

Share this post


Link to post
Share on other sites

Something isn't spot on load test the battery What is the voltage when turning Over the motor. Healthy battery don't drop below 10. 50, and as far as battery I go with trugel just because of the two year warranty and they are sealed and non mant. And with good spark and fine tuned jetting it should start with ease

Share this post


Link to post
Share on other sites

Turn fuel to prime, wait 30 seconds to ensure the float bowl is full, pull the choke, twist the throttle 2 times to full throttle, hit the starter. If it still has problems starting something is up.

Share this post


Link to post
Share on other sites

You should probably change the 7 amp standard battery for a 10 amp . You have to cut the back out of the battery box and get a bracket to hold the new battery , or get a smaller dry cell battery ( turntech ? ) Once you start trying to start the engine a bit , you will find the original standard battery just works , but will fail if you need to do a lot of turning over . The 7 amp just doesnt have enough cold cranking amps as a 10 amp does . Once I had done the cams ( hotcams ) on my SM , it got to the point that if it didnt start right up , I only got a few more tries , then the battery lost too much charge trying to start the bike and it wouldnt go . Changing to a larger capacity battery solved the problem and now the motor turns over very quickly , greg

06012012012.jpg

P1010043.jpg

The yellow battery is a 10 amp gell cell battery I just bought and the other pic is a wet cell 10 amp that I had before . You can see the bracket that holds it ( which eddie sells ) and how far it sticks out of the front of the battery box .

Edited by hinksy

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×
×
  • Create New...