Jump to content
Sign in to follow this  

09 Rattle, please help, I can't solve it.

Recommended Posts

I have 2 sick Yz250f's that I brought to fix up.

One is an 07 that skips in 5th (but doesn't rattle), its been stripped to order parts.

The other is the problem, I brought a 09 as a running bike with a loud rattle sounding like it was from the front/top. It's now been rebuilt serveral times and I'm at an end of ideas.

First I replaced the balance shaft bearings, made no differance,

then I swapped the 07 piston, barrel, complete head...no differance

swapped 07 cam chain...still rattles

Just done the main bearings...still bloody rattles.

What can I try next???

The rattle is through the whole rev range, and engaging the clutch or gears makes no differance.

Please help

Share this post


Link to post
Share on other sites

sounds like it has nothing to ddo with the engine...check your forks and triple tree bearings

no, its a loud alarming rattle/clattering noise from the engine.

Share this post


Link to post
Share on other sites

well you are going to have to put your ears down next to it.

is it left side or right side?

in gear or in neutral?

clutch engauged or not?

seems like a lot of parts replacement without much diagnoses.

Share this post


Link to post
Share on other sites

Did you check the crank to make sure there is no up and down play in it? Try removing the balancer in the front and start it up to see if there is any difference.

Share this post


Link to post
Share on other sites

clutch water pump oil tranny i think that you may be best off giving the engine a full tear down. you may find your issue only a few steps in or you may have to tear it completely apart. just keep an eye out for anything suspicious

Edited by antleo

Share this post


Link to post
Share on other sites

clutch water pump oil tranny i think that you may be best off giving the engine a full tear down. you may find your issue only a few steps in or you may have to tear it completely apart. just keep an eye out for anything suspicious

To replace the main bearings the cases have to be split, and again to replace the balance shaft bearings

Share this post


Link to post
Share on other sites

Did you check the crank to make sure there is no up and down play in it? Try removing the balancer in the front and start it up to see if there is any difference.

Yes, no up and down play, the con rod is only 10-15hrs old too. Will try swapping the balance shaft though

Share this post


Link to post
Share on other sites

well you are going to have to put your ears down next to it.

is it left side or right side?

in gear or in neutral?

clutch engauged or not?

seems like a lot of parts replacement without much diagnoses.

Its a loud noise so hard to pin point. When holding a screwdriver between the cases and my ear it sound maybe louder in the front, but is through the whole engine.

As stated above, it makes no differance if the bike is in gear of if the clutch is engaged or not

Share this post


Link to post
Share on other sites

Tried a few more things, and thinking it probably is the clutch basket/coller. what to change/buy though a basket, collar or both? And what would cause it??

Share this post


Link to post
Share on other sites

Tried a few more things, and thinking it probably is the clutch basket/coller. what to change/buy though a basket, collar or both? And what would cause it??

Have a look at the kickstart & idle gear.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×
×
  • Create New...