Jump to content
Sign in to follow this  

Switch problem or more serious?

Recommended Posts

Hello. I bought an 05 TTR 230 last week and I have a problem.

When running, the starter wants to stay engaged and keep trying to start. I think its in the starting switch. I have removed it from the handlebar and it seems to fix it. Is this a common issue?

Also, is the red light on the main ignition switch supposed to stay on at all times the bike is running? Mine wants to flash. I think its related to the switch issue.....

Any help would be appreciated.

David

Share this post


Link to post
Share on other sites

My dads TTR 230 had a problem with the kill switch causing it to never start. Taking it apart i noticed it had a small spring missing. (The previous owners attempts to disable it) Put a new spring in there, cranked right up. If its something else I don't know. I'm just sharing my experiences

Share this post


Link to post
Share on other sites

On my bike, the light stays on when the switch is ON, whether the engine is running or not. Leaving the switch ON with the engine not running is a good way to run down the battery, by the way.

I don't know if the switch problem is common. It's never happened to me, for what that's worth.

How do you know the starter is still trying to start with the engine running?

Share this post


Link to post
Share on other sites

Thanks for the help. Once I kill the bike using the kill switch, the bike is still trying to start. The light flickers and you can hear the bike still trying to start once I kill the bike using the kill switch. I am thinking bad contacts or sticky. Has anyone taken that switch apart?

Share this post


Link to post
Share on other sites

Once I kill the bike using the kill switch, the bike is still trying to start. The light flickers and you can hear the bike still trying to start once I kill the bike using the kill switch.

When you say the bike is still trying to start, does that mean the starter motor is turning continuously after you kill the engine? Both my TTR and WR make a short duration sound like the starter is turning right before the engine stops rotating when I kill the engine. I was concerned about that initially, but I've taken that to be normal. I think it has to do with the fact that these bikes have a constan-mesh starter. I haven't quite figured out exactly what that means, but I think some part of the starter is engaged all the time and that's what I think is making the noise at shutdown.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×
×
  • Create New...