Jump to content
Sign in to follow this  

Broken hot start threads

Recommended Posts

if you are saying that the plastic piece broke, then that is no big deal. Take a set of pliers and turn it out if you can grab onto it. If not, then get an easy out designed for removing a broken bolt. This can be found at the hardware store of your choice. A drill bit the right size would probably get it out too. Then I would look into getting an aluminum hot start nut. Pro Circuit sells them and some other companies. Should be about $25. Or order another plastic one for about $10 I'd think. Not a big deal. To post pics, you need an account with photobucket.com or some other online image storage site. Upload your photos to that site. Then copy the direct link to your photo from that site, and paste it into the box that comes up when you click the little picture icon in the reply/post box on TT. It is the green colored square about 10 icons over from the Bold/ITalic/Underline icons.

Share this post


Link to post
Share on other sites

Don't know why they make these damn things plastic I broke mine last week. 50 bucks for a new one

Share this post


Link to post
Share on other sites

Don't know why they make these damn things plastic I broke mine last week. 50 bucks for a new one

I'm surprised at that cost. Could have bought the Hot Start Plunger itself and it came with one.... I did the same thing, only I had to replace my plunger so I had to buy the whole thing.... Sucked but I did buy the PC nut and I have a extra one brand new plastic one.... Sorry I didn't reply on this earlier, I would have gave it to you for the cost of shipping. (2.00)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×
×
  • Create New...