Jump to content
Sign in to follow this  

Sudco FCR 39 jetting, need help please.

Recommended Posts

I have a Sudco FCR slant body (016-864) . My bike has a 3x3 , full FMF system , removed auto de-comp, performance air filter .

I cant find a breakdown for the FCR slant . All I know is that I have a 160 , 38 , 60, 200, and a needle that is marked OCEMM with the clip in the fourth slot from the top .

I am in chicago , about 600 ft above sea level .

Can anyone tell me if this combo will work or should I buy JD jet kit ? If the JD kit is the way to go , what should the settings be ? Any info would be helpful . I have tried searching , but come across too many combos . Thanks.

Share this post


Link to post
Share on other sites

That will work.

The only thing I see that is a little odd is the 60 pilot air jet and the 38 pilot fuel jet. There is a ratio between the 2 and that should work although more common is a 100 pilot air jet and 45 pilot fuel jet. If SUDCO delivered it with the 60/38 combo, then OK. You also might need to move the needle clip to -3 (from the top)

Share this post


Link to post
Share on other sites

That will work.

The only thing I see that is a little odd is the 60 pilot air jet and the 38 pilot fuel jet. There is a ratio between the 2 and that should work although more common is a 100 pilot air jet and 45 pilot fuel jet. If SUDCO delivered it with the 60/38 combo, then OK. You also might need to move the needle clip to -3 (from the top)

What about the air jet (on the intake bell side) ? Do I remove it ? How many turns out on the fuel screw ? Am I better off buying a JD kit ? Thanks for the info ,

Share this post


Link to post
Share on other sites

We just talked about the air jet. See above. No, you do not remove it from the slant body. No, no point in buying the JD kit. You could but the needle you have has been proven to work fine. EMM or EMN. The JD kit does not include pilot fuel or air jets. Just needles (2)and main jets. Adjust the fuel screw as needed, start at 2.5 turns.

Share this post


Link to post
Share on other sites

You are not too lean. Red glow is normal. Have you ridden it?

Share this post


Link to post
Share on other sites

You are not too lean. Red glow is normal. Have you ridden it?

I have not , but its popping , plus it doesnt seem to idle smooth and even . I will ride it tomorrow . How can a glowing red header pipe be normal ?

Share this post


Link to post
Share on other sites

Single wall exhaust pipe, no cooling air flowing past the pipe, flame inside.

Share this post


Link to post
Share on other sites

Still running lean after installing a 45 pilot . Same symptoms . High idle without the idle screw being used .

Edited by SUPERCHARGER

Share this post


Link to post
Share on other sites

Made some adjustments in the throttle cable that looked like it was catching , got it to run better , but still running lean and bogging off idle . Cant snap the throttle without a flat spot . I see that you guys wire the AP , but if I do that , the linkage seems to stretch the wire like the two dont want to stay together through the throttle cycle . Installed new seal in the slide and a pump diaphram . Once the bike is in motion , it seems to run well , but pops and backfires on de-cel . Forgot to mention that the diaphram I am using has the shorter nipple , its what Sudco sent instead of grinding it down .

Does anyone have an idea ? Should I raise the needle to clip 4 ? Thanks .

Edited by SUPERCHARGER

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×
×
  • Create New...