Jump to content
Sign in to follow this  

Funky Shifting Problem - Has anyone else seen this?

Recommended Posts

Thanks,

I did a cross country race on my 2010 YZ250 last weekend and while getting ready to load my bike after the race I noticed that my shifter was not returning when I was moving the lever in the down direction. I was fearing the worst! :thumbsup:

So I took the clutch cover off last night and pulled the clutch basket to take a look but initially everything looked fine. Then I noticed something very subtle as I was trying to figure out what the problem was. The torsion spring that re-centers the shifting mechanism had jumped off the tab that it is supposed to be in contact with.

I reset the spring into the groove in the tab and played around with the shifter a bit and it seems to be working just fine. I haven't reassembled the clutch yet because I need to get a new lock washer at the dealer today. So I haven't ridden it yet, but that is the plan, get it back together and take it out for a beating before the next race.

So the question is, has anyone else seen this problem before? Where the spring pops out of the groove on the tab?

It seems pretty odd to me, the spring doesn't look like it was bent or anything like that so I'm baffled as to how this could happen.

Just fishing for other's experiences.

Thanks,

trailhead

Share this post


Link to post
Share on other sites

I've never had it happen in the three modern (99 & up) YZ's, probably just the right circumstances to make it happen. I would re-assemble and ride it.

Share this post


Link to post
Share on other sites

I had some trouble with shifting on my last trip. I was searching for similar trouble on my way home. I found that what happened to you has happened to a good few others. I lucked out and my shifter bolt backed out.

Share this post


Link to post
Share on other sites

i had this happen to my 08 once before. the little tangs that hold the torsion spring in place wore out on mine just enough to let it slip off if i goon shifted. i replaced the shift shaft and spring and now it works great. also do not shift the bike without the inner clutch cover on the bike. the inner cover actually holds the shift in place. if you try and shift without the cover on the spring the spring will pop right back off. i learned this the hard way and messed with the shifter before putting the cover back on. i then bolted everything back together only to realize the damn spring had popped back off. talk about annoying.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×