Jump to content
Sign in to follow this  

Messed something up!

Recommended Posts

Hey all its been a long time since being on here. Bikes been sitting in the garage, broken, for a while now. Haven't had time to fix it with a little one now, fixing house, fixing trucks, blah blah!

Bike runs tops, the 4mm over kit is the cats meow and is way more then I need now. Got the rear end valved for me and thats working great, but I went to do the fork seals last year (leaking pretty bad) and I did them the same way I've done other, more simple, conventional forks. Pull spring and damper tube, pull dust seal and retaining ring for seal, then pounded the forks apart untill the seal came out. Put new seal in, new clip, dust seal, spring and damper rod, threaded cap on. BUT when I let the fork decompress the inner tube pushes out too far, not good. :thumbsdn:

I must have un-seated a bushing or something, but I can't figure out how to get the forks apart the right way. Right now if I pull the seal out I can only pull the upper tube out enough to see the milled down (smaller) section, won't come out all the way.

Any help is greatly appreciated, it was about 70 degrees and sunny out today and I can't stand seeing the bike just collecting dust in the garage any more. Eddie? :confused:

Share this post


Link to post
Share on other sites

Ya got that, my problems somewhere underneath the spring ha. Anyone ever do a re-valve? I'm more interested in how to fully take apart the forks, should be clear then.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×