• Content count

  • Joined

  • Last visited

Community Reputation

35 Excellent

About nickkx_f

  • Rank
    TT Silver Member

Profile Information

  • Location
  • Interests
    my son,girlfiend, and mx
  1. Have you checked to see that the valves are within spec? Also maybe see if the fuel pump is putting out the proper amount of fuel. How many hours on the bike and does the bike pop at all when riding?
  2. Why not try putting it back to stock and see what you get? Also what is this ktm knob you speak of for eliminating the hot start. Been wanting to do this but have no clue on what to use to fill that void.
  3. 450 is not the same and 10-17 rmz250 will work. If you're looking for a oversized tank no one makes one
  4. What part of pa you in?
  5. He I would look at the o ring because they are easy to pinch but is that the only place oil is coming from? I would look and see if the vent hose coming from the back of the motor is clogged or pinched. Could cause the motor pressurize and it's taking out the weakest parts.
  6. I probably have a little over three grand and if I was ever to sell I'd like 4K. I'll post up more pictures later
  7. I would take that he 14 over the 13. They changed the ecu on the 14 to help with starting. Have seen some 13s idler gear break and cases break. I have a 14 and love it but did have 2 13s and 10. Found my self hitting false neutral on everyone but my 14. Also have never had a issue with overheating. I've ran engine ice in all my bikes and never had a problem. Only bike I had overheat was a 08 Rmz450 in trails
  8. CamP can you private message me, I have a question about something if you don't mind. Sorry to jump in your thread tjs514
  9. My 2014
  10. I know this is a old topic you had but how did you ever get the bearings out?? I'm having the same issue right now. I used that same press you have and everything I can think of and they won't come out. If you can let me know how you got yours out that would be amazing!!
  11. Like the two post above said, get some bridgestones. My front would tuck all the time with the mx51 and I have the m403-m404. It sticks amazing in turns now. I feel a lot more confident going into a turn now with some good speed. The rear end worked for me after I set the sag but I went 2 clicks softer on the compression up front.
  12. Yeah it's not great but can be fixed
  13. Found out why the motor had issues and why it most likely isn't draining. Metal and fiber sitting all by the drain hole and I'm thinking it has some in the ports. Going to clean everything very well and blow everything out with air. Putting a new oil pump in as well from anything that past through that. Better safe then sorry
  14. I'll look when I get home. I have everything torn apart ready to split the cases