malik

Members
  • Content count

    9
  • Joined

  • Last visited

Community Reputation

10 Good

About malik

  • Rank
    TT Newbie

Profile Information

  • Location
    Bahamas
  • Interests
    dirt bikes
  1. hi i have an rm85 it was bored and has a fmf pipe it was running verry rich so i changed the reeds and now the bike will start for like 2 seconds and if i try to rev it it ill just bog down. A friend mentoned a pwk 28 carb to me would this solve my problem?
  2. hi i have a 2007 rm85 recently did a full rebuild . the last time i rode it it was runing and reving good in nutral but when i put it in gear it seemed to to sputter and the power would come in and out . a week after that i cranked to worm it up because i didnt ride it in a while i just cranked it and reved it a few times and i pressed the killswitch to cut it off. so today i put in a brand new plug in it and it wont crankover:banghead:. any advice would be appreaciated.
  3. hi, i have a 2007 rm 85 with a 105 big bore kit. the first i changed the spark plug put new gas in and i cranked it inside it ran great. so i cut it off so i could cary it outside to ride it and when i went outside it wouldent start. can you help me
  4. thanks.....i have a 2007 rm 85 with a 105 big bore kit. the first i changed the spark plug put new gas in and i cranked it inside it ran great. so i cut it off so i could cary it outside to ride it and when i went outside it wouldent start. can you help me
  5. thanks.....i have a 2007 rm 85 with a 105 big bore kit. the first i changed the spark plug put new gas in and i cranked it inside it ran great. so i cut it off so i could cary it outside to ride it and when i went outside it wouldent start. can you help me
  6. hi, i have a 2001 yz426f.. i just resentely cleaned the carb because the bike was a hard start and would bog if you let up of the gas.. however after puting the cleaned carb in the bike sounds like it wants to role over for a quick second however it dosent..... can anyone help me?
  7. and my brother has a yz426f he cleaned the carb and and whe we took it out today it didnt start
  8. i have a 2007 rm 85 and i changed my spark plug because it got very oily and when i start it it bogS AND IT CUTS OFF. CAN YOU HELP ME