Jump to content

outtydad

Members
  • Content Count

    6
  • Joined

  • Last visited

About outtydad

  • Rank
    TT Newbie

Profile Information

  • Location
    New Brunswick

Recent Profile Visitors

46 profile views
  1. I have a 2009 WR300 I bought not long ago. Awesome bike! When I did my first oil change it had no washer for the drain plug.. is this normal? Also it needs new brakes...where is a good place to pick up brakes? I've used EBC before and like them... does anyone have a part numbers for both front and back? I've been looking in this site but can't find the info. Thanks
  2. outtydad

    09 WR 300 wiring help

    I just bought an 09 WR300 and the previous owner had a number plate on the front, but put the headlight back on before I bought it, with a box of assorted wires. Unfortunately he didn't wire it in... so I have a 1/2" x 1/2' white connector on the light that I cannot find any wires in the box to fit. He also removed the speedometer pod... I also can't find anywhere to wire that in. Does anyone have a wiring diagram (with pictures for dummies like me) that would help me out?
  3. outtydad

    Bike Shuts off?

    sticking switch
  4. outtydad

    Bike Shuts off?

    Bingo! Thanks Colorado Kid
  5. outtydad

    Bike Shuts off?

    I have a 2007 KLX 250 and when I go to let the cluch out it quits. It starts up and runs fine, if it's in nuetral I can pull clutch in and out no prob, but as soon as it's in gear and I just start to let the clutch out it instantly dies... is there some electrical wire that may be shorting? Thanks Wayne
  6. I have a 2007 Kawasaki KLX 250s that I bought a month or so ago, so I haven't had any running time on it. I started it up today ( choked it ) and it idles fine, but when I tried to give it little shots of gas, it sputtered and quit each time. I thought it wasn't warmed up yet and tried a couple minutes later and it did the same, then finally quit and won't start? Any thoughts? thanks
×