Frisco 415

Members
  • Content count

    12
  • Joined

  • Last visited

Community Reputation

0 Neutral

About Frisco 415

  • Rank
    TT Newbie

Profile Information

  • Location
    California
  1. My drz400 was stolen and when I recovered it it had the 4 ignition switches cut. I connected them by crimping the wires back together, but still get nothing out of the bike. I looked and I can't find any other wires cut or any other damaged parts to the bike. The fuse and battery are both still good. What is my next step to find out what I need to do?
  2. Thanks for all the help going to take a look and see what I can do
  3. All the lights turn on like normal then I hit the start button and nothing happens... and no I don't have the kill switch on. Then I connect the two relay bolts on the side with a metal object and it starts up no problem. WHAT THE HELL IS GOING ON! and Im supposed to be heading on a trip saturday
  4. My bike has been running great... then I left it for about 2 hours and came back and tried to turn it on but nothing would happen. I just got a new battery about a month ago, so I don't think that is the problem. Any ideas?
  5. Im looking for a new engine for a suzuki drz400s 05 or even a rebuilt one where could I find it?
  6. Having some issues with misfiring with my drz lately and my buddy told me to check my spark plug wire and it turned out to have a 14,970 OHM reading and I was just wondering what it should be at. Thanks for the help in advance
  7. My exhaust cap fell off when I was riding the other day and I was just wondering if I could leave it like that or is that a bad idea?
  8. I have dunlop d606 on the rear and im looking for a good match on the front. I ride on the street everyday and ride on dirt maybe 5 times a month.
  9. punctured my gas tank while putting in screws for the plastic on the side. Did not go all the way through but it still leaks. Is there any way to plug it?
  10. There is a hissing noise coming from my bike it seems like the left side of the radiator, but not the right. It also seems to get worse when I go faster, but is not always there. What is this and how do I fix it? Thanks in advance
  11. Im talking about the clear thing that is located in the "v" looking thing that the frame makes. Thanks for the help.
  12. There is a clear looking gasket on the left side of the bike right above the chain. What is this? does it need any fluids? because mine looks like there was some type of liquid that was evaporated. But I can't figure out what it is.