Jump to content

Mikethe80srocker

Members
  • Content Count

    147
  • Joined

  • Last visited

About Mikethe80srocker

  • Rank
    TT Bronze Member

Profile Information

  • Gender
    Male
  • Location
    Saskatchewan
  • Interests
    Dirt bikes , Cars , Guitars , loud rock music ...

Recent Profile Visitors

362 profile views
  1. Mikethe80srocker

    The start of a long Restoration ... YZ 250

    New pic with the proper Black tank decals !!! Engine goes out for tear down & rebuild next week ... YES !!!!!
  2. Mikethe80srocker

    83 RM 80 Won't start ...

    2nd pic , right side shows a mark on the mounting bracket , that was the top ( Pointing up towards the gas tank ) , or at least thats how it came out of the bike . I'll give it a shot , i've got nothing to loose at this point . I'll report back when get it done . ( If it fires up , that would mean that the coils are in backwards i assume ?? )
  3. oem tank , sanded and painted ... all other plastics are new .
  4. Mikethe80srocker

    83 RM 80 Won't start ...

    I took some pics of the stator ... can anyone see a problem ??
  5. Mikethe80srocker

    83 RM 80 Won't start ...

    So is it a matter of just swapping the stator coils side to side on the plate ?
  6. Mikethe80srocker

    83 RM 80 Won't start ...

    I had an intermittent / no spark issue before . replaced all the usual suspects tying to diagnose this issue . It ended up being the stator ... Is it possible to now have spark , with the stator installed wrong ?
  7. Mikethe80srocker

    83 RM 80 Won't start ...

    I told my son not to mess with Suzuki's ... lol lol
  8. Mikethe80srocker

    83 RM 80 Won't start ...

    I have a spark tester , it will jump an easy .040 gap . Strong spark ... Plugs are all new ones , one standard copper core , the other 2 are Irridium . NGK brand .
  9. I hope its ok , to post this even though it's not complete yet , ..... but soon it will . ( 1984 YZ 250 )
  10. Mikethe80srocker

    83 RM 80 Won't start ...

    Great feed back guys ! Thank you . I will try to answer the comments the best i can . No restrictions in the exhaust , its been thoroughly checked . The piston has been installed properly , i made sure 100% . I checked the crank shaft key and it appears to be intact , nothing looks to have moved . I checked the crank seals for leaks , and nothing obvious showed up . It was not burning oil or smoking real bad before this started . With the pot off , i used some light compressed air and blew out the bottom of the crankcase , there was a lot of gas/oil accumulated from repeated kick starting . The bike has not sat for any great length of time . Thanks again for everyone's input on this matter !! It's very much appreciated .
  11. Mikethe80srocker

    The start of a long Restoration ... YZ 250

    Like the title says , it's been a long down out process getting this YZ of mine back into shape ... Here it is so far ... now just a few things left , and its near done . The graphic shop who did my tank decals messed up and did them in blue instead of black !!! This will have to be changed ... It's an 84 , but i like the 85 tank decals better ... so i went with them .
  12. Mikethe80srocker

    83 RM 80 Won't start ...

    One thing that we have checked and find a bit suspicious is when you kick it over you can feel some air rushing out the inlet of the carb .... After doing some reading online , some say that could be a sign of trouble ... We had the reed cage out and had a look at it closely , and it looked ok ... the reed was in the fully shut position . If you took a small screw driver and pushed very lightly on the back side of the reeds , they would open no problem , and close as they should .
  13. Mikethe80srocker

    83 RM 80 Won't start ...

    New premium gas mixed properly with a good quality oil . 20:1 ratio After 10 kicks the plug is wet , and needs to be removed and cleaned off etc . We checked ( the best we could ) for crank seal leaks , air leaks in general - no problem found .
  14. Mikethe80srocker

    83 RM 80 Won't start ...

    Been fighting this little bike for months with all kinds of problems . Worked though a few and got the bike all back together and still ... it won't start . Things I've done : rebore cylinder w/ new piston , rings , spark plugs (3), new stator , new coils (3) , CDI box (2) , rebuilt the carb . Things i have checked : Name it !!! I've checked them ALL .... ( feel free to ask ) Its got spark , and lots of it , it's got fuel ...lots of it , it's got great compression as its an all new top end . But it still will not run ! When you kick it over , once out of every 5-7 kicks it will POP out the exhaust pipe . Any suggestions or help would be much appreciated . Thank you ! Bike pic for reference only ( Pic from the net , not mine )
  15. Mikethe80srocker

    Second chances. (Graphic warning)

    Some might say you have a " Chip on your shoulder " !!! All jokes aside , its good to see your ok !!! Take Care !
×