Jump to content

jpeck75

Members
  • Content Count

    4
  • Joined

  • Last visited

About jpeck75

  • Rank
    TT Newbie

Profile Information

  • Location
    California
  1. jpeck75

    2012 WR450 YAMAHA

    I picked up some yesterday and will be applying it in the next couple days. I appreciate the advice brother!! Next run will be MLK weekend in Ocotillo Wells and I'll see how it works. I picked up some yesterday and will be applying it in the next couple days. I appreciate the advice brother!! Next run will be MLK weekend in Ocotillo Wells and I'll see how it works.
  2. jpeck75

    2012 WR450 YAMAHA

    Thanks brother. I did reuse that seal/washer since it appeared to be in good condition. But, from what you’re saying about the popping and what I’ve read about a hot header, I think I need to change it out. Thanks again.
  3. jpeck75

    2012 WR450 YAMAHA

    I bought my 2012 WR450 new, but have only recently been able to start riding again. I have recently done the following and am still dialing it it. Hope this gives you some ideas. 2012 Yamaha WR450 FMF Racing Power Core 4 HEX Slip-On Exhaust FMF Megabomb Header GYTR Competition ECU ASV Levers IMS 3.0 Gallon Fuel Tank Snorkel Removed UNI Air Filter Re-sprung front and back, Re-valved front I primarily do long distance endure riding and am experimenting with Maps. MAPS I’ve tried: -Modded WR450 Map (popping on deceleration, jerky on low gears, good top end, glowing red header) -Aussie WR450 Map (some popping on deceleration, short flame when it pops, not as jerky on low gears, good top end, glowing red header) -Smooth Bottom/ Rush on top WR450 Map (some popping on deceleration, short flame when it pops, much smoother on low gears, good top end, getting about 28 MPG) -Going to try other MAPS next trip to find the sweet spot.
  4. I have a 2012 WR450 and the main headlight is not working. Not street legal (no turn signals/ not plated) When I depress the on/off button the auxiliary light and the tail light do come on. When I start the bike, the headlight does not come on. I have put the bike in gear and the headlight doesn't come on. I have checked the following: Battery connections: Good Battery charge: Good (new battery) Headlight Relay: Good Bulb: Good (Checked continuity with no resistance) Even installed a new bulb. Voltage to bulb: Good (removed the connector from the back of the bulb. Depressed the on/off switch: no vdc. Turned on the bike: approx 12 vdc) All Fuses: Good Multi-ground connector: Good (disassembled, cleaned, connector gel applied) Generator output: Good (checked at battery connection not running: 12 vdc. checked at battery connection when running: 13.5-14 vdc) A few rides ago the headlight came on for a while and then turned off. It has not turned on since. I have removed nearly every connection on the bike and looked for any signs of corrosion or water intrusion. Nothing. Applied connector gel on each before re-connecting. I am at a loss now and am out of ideas. Does anyone have any more ideas as to what I am missing? It seems like everything in the light circuit is operating as required, but nothing happens. Thanks for all the help. 2012 Yamaha WR450 FMF Racing Power Core 4 HEX Slip-On Exhaust FMF Megabomb Header GYTR Competition ECU ASV Levers IMS 3.0 Gallon Fuel Tank
×